expo build:ios (on Windows 10) gets: Error while gathering & validating credentials

Hi everyone,

I run expo build:ios on Windows 10 and got following error:

[09:58:39] Error while gathering & validating credentials
[09:58:39] Error: Reason:Unknown reason, raw:“Could not receive latest API key from App Store Connect, this might be a server issue.”
[09:58:39] Reason:Unknown reason, raw:“Could not receive latest API key from App Store Connect, this might be a server issue.”
[09:58:39] Error: Reason:Unknown reason, raw:“Could not receive latest API key from App Store Connect, this might be a server issue.”
at Object._callee4$ (C:\expo-cli@2.6.14\src\commands\build\auth.js:135:11)
at tryCatch (C:\Users\szage\AppData\Roaming\npm\node_modules\expo-cli\node_modules\regenerator-runtime\runtime.js:62:40)
at Generator.invoke [as _invoke] (C:\Users\szage\AppData\Roaming\npm\node_modules\expo-cli\node_modules\regenerator-runtime\runtime.js:296:22)
at Generator.prototype.(anonymous function) [as next] (C:\Users\szage\AppData\Roaming\npm\node_modules\expo-cli\node_modules\regenerator-runtime\runtime.js:114:21)
at step (C:\Users\szage\AppData\Roaming\npm\node_modules\expo-cli\node_modules\babel-runtime\helpers\asyncToGenerator.js:17:30)
at C:\Users\szage\AppData\Roaming\npm\node_modules\expo-cli\node_modules\babel-runtime\helpers\asyncToGenerator.js:28:13
at
at process._tickCallback (internal/process/next_tick.js:189:7)

I’ve read this forum topic and many others, tried to fix as recommended, but they didn’t work.

You should know that I have just created my apple id today, so it might cause the problem. I’m not certain whether the validation/activation takes time.

Do you have server issues or did you stop to support anything I should be aware of?

Would be great if you could help.

Hey @szage2,

Account activation takes up to 24h https://developer.apple.com/support/purchase-activation/

Let us know if you still have issues after you know your Apple Developer account has been activated.

Cheers,

Adam

Hello @adamjnav,

Thank you for your reply. Unfortunately I still have the same issue.
Can you look into it again?

What shell are you using on Windows?

@adamjnav,

I’m Running expo-cli version 2.6.14 from Windows-based command line.

Hi again,

Update: I’ve upgraded expo version for 2.7.1. … and still get the same error. Any advice?

Can you try clearing out your credentials via expo build:ios -c and starting from a clean slate?

Hi @adamjnav,

Tried it, but didn’t work. Is there anything else I could do?

I don’t see the what’s wrong as building the android version worked perfectly.

Thanks.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.