Expo CLI 2.0 not installing on Windows 10 with npm

#1

I’m running Windows 10. I’m getting the following error when running:

npm install -g expo-cli

npm ERR! Error: EPERM: operation not permitted, rename 'C:\Users\username\AppData\Roaming\npm\node_modules\expo-cli\node_modules\aws4\package.json.694729986' -> 
'C:\Users\username\AppData\Roaming\npm\node_modules\expo-cli\node_modules\aws4\package.json'
npm ERR! The operation was rejected by your operating system...

None of the following worked:

  • Running command as administrator
  • Excluded …\Roaming\npm\node_modules from McAfee antivirus (with “Exclude subfolders”)
  • Upgraded Node.js to 11.1.0
  • Made sure I can write to the folder and it is not read-only

I can work around this problem by downgrading back to exp version 55.0.5, then it works again, but this does not solve the problem and I want to use expo-cli.

Is there a solution for this issue?

1 Like
closed #2

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.