expo-cli downloading but cannot be used


#1

I used some linux to check if expo-cli actually downloaded:

npm list -g | cat $1 | grep -i expo

├─┬ expo -cli@2.7.0
│ ├─┬ @ expo /bunyan@3.0.2
│ ├─┬ @ expo /dev-tools@0.2.33
│ ├─┬ @ expo /json-file@8.1.0
│ ├── @ expo /simple-spinner@1.0.2
│ ├─┬ @ expo /spawn-async@1.3.0
│ ├── @ expo /traveling-fastlane-darwin@1.6.2
│ ├── UNMET OPTIONAL DEPENDENCY @ expo /traveling-fastlane-linux@1.6.2
│ ├── @ expo /bunyan@3.0.2 deduped
│ ├── @ expo /json-file@8.1.0 deduped
│ ├─┬ @ expo /ngrok@2.4.3
│ │ ├─┬ @ expo /ngrok-bin@2.2.8-beta.3
│ │ │ ├── UNMET OPTIONAL DEPENDENCY @ expo /ngrok-bin-darwin-ia32@2.2.8
│ │ │ ├── @ expo /ngrok-bin-darwin-x64@2.2.8
│ │ │ ├── UNMET OPTIONAL DEPENDENCY @ expo /ngrok-bin-freebsd-ia32@2.2.8
│ │ │ ├── UNMET OPTIONAL DEPENDENCY @ expo /ngrok-bin-freebsd-x64@2.2.8
│ │ │ ├── UNMET OPTIONAL DEPENDENCY @ expo /ngrok-bin-linux-arm@2.2.8
│ │ │ ├── UNMET OPTIONAL DEPENDENCY @ expo /ngrok-bin-linux-arm64@2.2.8
│ │ │ ├── UNMET OPTIONAL DEPENDENCY @ expo /ngrok-bin-linux-ia32@2.2.8
│ │ │ ├── UNMET OPTIONAL DEPENDENCY @ expo /ngrok-bin-linux-x64@2.2.8
│ │ │ ├── UNMET OPTIONAL DEPENDENCY @ expo /ngrok-bin-sunos-x64@2.2.8
│ │ │ ├── UNMET OPTIONAL DEPENDENCY @ expo /ngrok-bin-win32-ia32@2.2.8-beta.1
│ │ │ └── UNMET OPTIONAL DEPENDENCY @ expo /ngrok-bin-win32-x64@2.2.8-beta.1
│ ├─┬ @ expo /osascript@1.9.0
│ │ ├── @ expo /spawn-async@1.3.0 deduped
│ ├─┬ @ expo /schemer@1.2.2
│ ├── @ expo /spawn-async@1.3.0 deduped

Thank you.


#2

Hey @ymoondhra,

It looks like someone provided an answer on SO. It looks to be a PATH issue. Can you try their suggestions and let me know if it works for you.

Cheers,

Adam


#3

I solved it! Answer is on my stackoverflow post.