Expo constant dependency 'uuid/v4' not resolved

Hi guys…

I think I’ve made a very very bad mistake.
Not knowing that the expo itself is using uuid dependency, I’ve installed the latest version of it and deleted it.

Now each time the expo tool tries to bundle my app for web, it runs into below error.

C:/Users/ksi93/ezi-crm/node_modules/expo-constants/build/ExponentConstants.web.js

Module not found: Can't resolve 'uuid/v4' in 'C:\Users\ksi93\ezi-crm\node_modules\expo-constants\build'

What I already tried

  • replacing uuid with custom made random id generator for each file that depended on uuid (gave up as I thought that it might not be a good idea)
  • installing other uuid modules (nope)
  • deleting node_modules folder and installing again.

Thanks for your help in advance.

Hi guys,

I actually figured the fix.
I found the dev-dependency expo constant module was using and the version of uuid was different obviously.

If anyone run into this issue, just remove all other uuid modules and add below depenency to your package.json, then ‘npm install’

“uuid”: “^3.3.2”

1 Like

Hey @ksi9302,

Glad you got things figured out. Another good idea when you get caught in a dependency conflict like this is to delete your node modules and then try clearing all your caches.

Cheers,
Adam