Expo ide with Window BASH


#1

I truly wish expo xde to work well in window bash.

Currently, I felt this is running on window dos when starting packager because
I’ve installed my npm and nodejs in window bash and expo xde won’t access it.

I figured it out by installing nodejs and git again in window.

When I develop my webpage using vue, it works perfectly just using window bash. Therefore I felt it is unnecessary to install dev tools in window but had to when developing with expo xde.

Hope this issue is in expo xde’s update list.

Thank you.


#2

Are you talking about the bash terminal that you get with the Windows Subsystem for Linux? I’m just asking because you can also get bash by installing GIT for Windows.

Expo XDE works perfectly for me in Windows 10 without bash.


#3

I am talking about Windows subsystem for linux.

I know Expo xde works on windows 10 but I recently uninstalled all nodejs and npm in window
because there were some confilct when I tried to used window’s npm in linux bash.

Therefore installed nodejs and npm again in linux bash and worked well when I just develop on web programming.
However, with expo, it won’t work. Therefore, now I have nodejs and npm installed in both window and linux bash which I don’t feel like it.

Also I am using visual studio code and I set default terminal as linux bash and this just feels so messy to me that I have to change it when I develop for expo (not as beautiful). I hope expo xde have some settings to set default terminal or default npm path or something like these to work nicely in linux bash too.


#4

Hi! I suspect that if you use exp in WSL, it will work better, as it doesn’t rely on GUI tools.


#5

I am sorry but what does WSL stands for?


#6

Windows Subsystem for Linux – it’s the official name of the “ubuntu on windows” feature.


#7

Thanks for sharing.

Also I’ve already tried what you told me here. I faced ambiguous problem when trying to launch my expo app in my android device because WSL can’t reach my Android’s usb device. I’ve searched for this issues and coudln’t found the solution. Neither will work on genymotion until I install gui for WSL which I won’t do it.


#8

Yeah, I’m not sure what the state of WSL is with regard to USB drivers and communications. If you use the network tunnel without the USB cable you should be able to get it to work. That said, at the moment I don’t think we have the resources to make this a super high priority.

If you’d like official support for our developer tools on WSL/ubuntu-on-windows, can you open a feature request? Thanks!


#9

I run my expo project with the default npm start script, and it appear as what I saw in windows power shell , without showing any errors. But after I typed in exp://my ip:19000 in my expo app, it failed to connect, which told me that my app was not running at exp:// my ip:19001. Something wrong? Please help, thank you friends.