Expo Local Authentication issue if you have more than 1 apps installed on IOS

Hey guys! I need your help to figure out the specific bug in IOS but that only shows up if you have more than 1 app using LocalAuthentication.
I have 2 IPA installed in my IOS device, expo Local Authentication TouchID/FaceID doesn’t work on the first installed IPA but works on the last installed IPA. But working perfectly in Android. Can you please help me with that issue.
Thanks !

do the IPAs share similar metadata? If the error you’re getting is the same as the one posted in this issue, you should provide unique values to expo.ios.infoPlist.CFBundleExecutable for each app

Otherwise, it’d be very helpful to post the actual error you’re getting :smile:

No, I dont get any error. What happens is when I install 2 IPAs(having expo LocalAuthentication) in same iPhone device. The last installed ipa trigger the TouchID/FaceID, but the first installed ipa doesnt trigger the TouchID/FaceID.
But both apps working fine in Android.

whats with that? where to add it and how to write it? kindly write it :sweat_smile:

https://docs.expo.io/versions/latest/config/app/#infoplist

For 1st app:

“ios”: {
“supportsTablet”: true,
“bundleIdentifier”: “com.aivatek.onquest”,
“infoPlist”: {
“NSCameraUsageDescription”: “This app uses the camera to scan barcodes on event tickets.”,
“NSFaceIDUsageDescription”:“This app uses the camera to scan Face.”,
“CFBundleExecutable”: “ResidentApp”
}

For 2nd app:

“ios”: {
“supportsTablet”: true,
“bundleIdentifier”: “com.aivatek.onquestcaptain”,
“infoPlist”: {
“NSCameraUsageDescription”: “This app uses the camera to scan barcodes on event tickets.”,
“NSFaceIDUsageDescription”: “This app uses the camera to scan FaceID.”,
“CFBundleExecutable”: “CaptainApp”
}
},

This is what I added in my app.json file. Is that correct?

that is correct, but if you’re not getting the same or similar error message as is reported in the issue I linked, then it might not solve things for you since it could be a different issue.

Are you try/catching the call to LocalAuthentication?

No, I am not getting any error. The thing is when I uninstall the last installed app, the other app start triggering TouchID/FaceID perfectly.
Its just stop working in the app when I install another app of mine, that using expo local authentication TouchID/FaceID. :frowning_face:

I just debug it and found out the error

“error”:“unknown: -1004, User interaction is required.”

I did everything what they asked to do in the link https://github.com/expo/expo/issues/663#issuecomment-510800151, but didnt find any success.

Okay finally I solved it!!! @charliecruzan @notbrent
My both apps were using expo sdk 38 and react-native sdk 38.
I just downgraded only one app to

“expo”: “^36.0.0”,
“react-native”: “https://github.com/expo/react-native/archive/sdk-36.0.0.tar.gz

the other app still using sdk 39. and then I removed the node_modules and package-lock.json from the downgraded app.

sudo rm -rf ./node_modules && sudo rm -rf package-lock.json

and then I Installed new modules in it

npm i

solved some compatible warning of libraries by doing

expo install “Library name”

Built the app, and installed both apps and it worked!!. :slight_smile: