Expo publish to play store required Android API Level 28 (New policy starting first Aug)

Recently we build Android Apps using react expo and build signed APK using bellow command expo build:android -t apk or Android App Bundle expo build:android -t app-bundle

After we build signed APK, we tried to upload to Playstore and some error appears that wanted us to upgrade target API from 26 to 28. Have explored and reading several QA at SO and any other forum then many of them are intended for React Native. How we can publish our APK to Play Store?

Here are app.json

{
  "expo": {
    "name": "***",
    "slug": "***",
    "privacy": "public",
    "sdkVersion": "32.0.0",
    "platforms": [
      "ios",
      "android"
    ],
    "version": "1.2.3",
    "orientation": "portrait",
    "icon": "./assets/logo.png",
    "splash": {
      "image": "./assets/splash.png",
      "resizeMode": "contain",
      "backgroundColor": "#ffffff"
    },
    "updates": {
      "enabled": true,
      "checkAutomatically": "ON_LOAD",
      "fallbackToCacheTimeout": 0
    },
    "assetBundlePatterns": [
      "**/*"
    ],
    "ios": {
      "supportsTablet": true
    },
    "android": {
      "package": "com.qreatiq.foodmart",
      "permissions": [
        "CAMERA"
      ],
      "googleServicesFile": "./google-services.json",
    },
  }
}

We’ve tried to check the documentation here and there are property for compileSDKVersion or related like native apps.

In Native app we can easily configure as bellow

compileSdkVersion 27
buildToolsVersion "27.0.3"
minSdkVersion 16
targetSdkVersion 27

How to do that at React Expo?

Update 1
after reading from developer.android.com

When you upload an APK, it needs to meet Google Play’s target API
level requirements. Starting August 1, 2019, Google Play requires that
new apps target at least Android 9.0 (API level 28), and that app
updates target Android 9.0 from November 1, 2019. Until these dates,
new apps and app updates must target at least Android 8.0 (API level
26).

Still doesn’t have any idea for those things. Please help.

Expo SDK v33 (and later) are required for submitting to the Google Play store after 2019-08-01.

From the blog post about SDK v33:

We recommend that all Expo developers with Android apps upgrade to SDK 33 now to front-load most of the work required for creating 64-bit APKs, coming in SDK 34, and necessary to submit to Google Play in August.

See also the v34 SDK blog post: