Expo required expo-location

Please provide the following:

  1. SDK Version: 38
  2. Platforms(Android/iOS/web/all): Android / iOS

Hi, I’m using expo to build an application and I tried to publish on Google Play the new version of the app.
But after doing it the noticed that the application uses location and asked me what is the usage.
I didn’t use the location on the app, but I noticed that Expo include in dependencies (https://github.com/expo/expo/blob/sdk-38/packages/expo/package.json#L67).
Is there any reason for this ? And what is the justification to the Google Play console can I give ?

Thank you

Hey @aubin_grd, this is expected if you are using the Managed workflow. You can read more on this here: https://github.com/expo/fyi/blob/master/managed-app-size.md

As for a reason, we’ve found that detailing what I linked to as the reason for the location module inclusion has worked for developers before. (As long as your app doesn’t target children)

Cheers,
Adam

@aubin_grd Have a look at this reply of mine, might your issue as well: