EXPO SDK 37 - App Store Rejection - ITMS-90809: Deprecated API Usage

  1. SDK Version: 37
  2. Platforms(Android/iOS/web/all): all

Hi

I am trying to upload first build of my app to the app store, it is being rejected with the following message:

App Store Connect\ 173x45

Dear Developer,

We identified one or more issues with a recent delivery for your app, Please correct the following issues, then upload again.

ITMS-90809: Deprecated API Usage - New apps that use UIWebView are no longer accepted. Instead, use WKWebView for improved security and reliability.

I have seen several posts about this issue but they all seem to point to upgrading to the latest SDK, and I am already on 37. Any ideas here? Below is my list of dependencies:


"@expo/samples": "~3.0.3",
    "@expo/vector-icons": "^10.0.3",
    "@react-navigation/web": "^1.0.0-alpha.9",
    "@svgr/cli": "^5.1.0",
    "dayjs": "^1.8.17",
    "expo": "^35.0.0",
    "expo-asset": "^7.0.0",
    "expo-av": "~7.0.0",
    "expo-constants": "^7.0.0",
    "expo-font": "^7.0.0",
    "expo-linear-gradient": "~7.0.0",
    "expo-web-browser": "^7.0.0",
    "firebase": "^7.5.1",
    "global": "^4.4.0",
    "npx": "^10.2.2",
    "prop-types": "^15.7.2",
    "react": "16.8.3",
    "react-dom": "16.8.3",
    "react-native": "https://github.com/expo/react-native/archive/sdk-35.0.0.tar.gz",
    "react-native-gesture-handler": "~1.3.0",
    "react-native-modal-selector": "^1.1.1",
    "react-native-radio-buttons": "^1.0.0",
    "react-native-svg": "~9.9.2",
    "react-native-typography": "^1.4.1",
    "react-native-web": "^0.11.7",
    "react-navigation": "^3.12.0",
    "react-navigation-hooks": "^1.1.0",
    "sharp-cli": "^1.13.1",
    "uuid": "^3.3.3"

Dankurf, did you make sure to update all dependencies accordingly?

Im seeing the following:

"react-native": "https://github.com/expo/react-native/archive/sdk-35.0.0.tar.gz",

Also your Expo version is @ 35.

You are basically still loading SDK35? We update to SDK37 and for us it is "react-native": "https://github.com/expo/react-native/archive/sdk-37.0.0.tar.gz".

In this article https://blog.expo.io/expo-sdk-37-is-now-available-dd5770f066a6#0d88 it explains how to upgrade.

I hope this helps.

Thank you @dept , that was the issue , I had not done this before!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.