Expo start android: Couldn't start project on android

Hello,
I’m trying to run my app on Android Studio Emulator. I’ve set this up following the instructions on your site ( https://docs.expo.io/workflow/android-studio-emulator/ ) . I’ve carefully implemented each step. However when I try to run expo start --android the log in the metro bundler just says: ‘Couldn’t start project on android’ with no additional error messages or anything. I have no idea what could be wrong.

Some info that might be helpful:

//.bash_profile
export JAVA_HOME=/Library/Java/JavaVirtualMachines/openjdk-12.0.2.jdk/Contents/Home
export ANDROID_HOME=/usr/local/share/android-sdk
export ANDROID_SDK_ROOT=/usr/local/share/android-sdk
export JAVA_HOME=/Library/Java/JavaVirtualMachines/openjdk-12.0.2.jdk/Contents/Home
export ANDROID_HOME=/usr/local/share/android-sdk
export ANDROID_SDK_ROOT=/usr/local/share/android-sdk
export PATH=/Users/max/Library/Android/sdk/platform-tools:$PATH
export ANDROID_SDK=/Users/max/Library/Android/sdk

Expo CLI 3.20.9 environment info:
System:
OS: macOS 10.15.4
Shell: 5.7.1 - /bin/zsh
Binaries:
Node: 13.10.1 - /usr/local/bin/node
Yarn: 1.21.0 - /usr/local/bin/yarn
npm: 6.14.5 - /usr/local/bin/npm
IDEs:
Android Studio: 3.6 AI-192.7142.36.36.6392135
Xcode: 11.4.1/11E503a - /usr/bin/xcodebuild
npmPackages:
expo: ^37.0.0 => 37.0.7
react: 16.9.0 => 16.9.0
react-dom: 16.9.0 => 16.9.0
react-native: https://github.com/expo/react-native/archive/sdk-37.0.0.tar.gz => 0.61.4
react-native-web: ~0.11.7 => 0.11.7
npmGlobalPackages:
expo-cli: 3.20.9

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.