Expo v33 IOS cannot install react-native-firebase due to incompatible GoogleUtilities

EXFaceDetector -> GoogleMobileVision/FaceDetector -> GoogleMobileVision/Detector

  - GoogleMobileVision/Detector (1.1.0):
    - GoogleInterchangeUtilities (~> 1.2)
    - GoogleNetworkingUtilities (~> 1.2)
    - GoogleUtilities (~> 1.3)

GoogleMobileVision/Detector require GoogleUtilities (~> 1.3)and 'Firebase/Core', '~> 5.20.1' require GoogleUtilities (->5.8.0)

Because of this, after pod install, GoogleUtilities is broken which cause
compile error 'GoogleUtilities/GULAppEnvironmentUtil.h file not found in FirebaseCore

3 Likes

Encountering the same issue here, everything was working in SDK 32, but it’s broken in SDK 33.
Any ideas? Is it possible to not load EXFaceDetector when using unimodules as a temp fix?

Actually the fix is documented here: https://github.com/expo/expo/issues/4493

1 Like

Thanks!!