Expo XDE not working


#1

What are the possible reasons that XDE stucks, and Publish/Share/Device button are disabled please?

While the same CRNA project runs well with “yarn start”

p.s.
XDE 2.22.1
exp 49.0.1

package.json:

{
“name”: “Awesome”,
“version”: “0.1.0”,
“private”: true,
“devDependencies”: {
“react-native-scripts”: “1.11.0”,
“jest-expo”: “23.0.0”,
“react-test-renderer”: “16.0.0”
},
“main”: “./node_modules/react-native-scripts/build/bin/crna-entry.js”,
“scripts”: {
“start”: “react-native-scripts start”,
“eject”: “react-native-scripts eject”,
“android”: “react-native-scripts android”,
“ios”: “react-native-scripts ios”,
“test”: “node node_modules/jest/bin/jest.js --watch”
},
“jest”: {
“preset”: “jest-expo”
},
“dependencies”: {
“expo”: “^23.0.4”,
“react”: “16.0.0”,
“react-native”: “0.50.3”
}
}


#2

Hi @ernestlin - sorry you’re having trouble. It looks like we pushed out an outdated version of CRNA recently. Could you upgrade to the latest CRNA version and try again with a newly created project? Let us know if you’re still seeing the issue after that.


#3

Hi @esamelson, thank you for responding. My goal is to build a standalone app and dynamically update my JS bundle. Before that, I try to publish but always stuck…

Still cannot publish with XDE and below are my steps:

  1. $ create-react-native-app AwesomeAgain
  2. $ yarn
  3. $ yarn start
  4. Open project in XDE, but packager address not auto displayed until I press the gear icon.
  5. $ sudo lsof -nP -iTCP -sTCP:LISTEN
    Expo\x20X 60984 ernie 24u IPv6 0x818271798811b3df 0t0 TCP *:19000 (LISTEN)
    Expo\x20X 61032 ernie 33u IPv6 0x8182717988117a5f 0t0 TCP *:19001 (LISTEN)
  6. Manually input addr in Expo App
  7. Modify App.js and the app can be hot reloaded.
  8. Publish/Share/Device buttons are still disabled.

With another CRNA hello world project running “exp publish”:

XDE 2.22.1
exp 49.0.1
create-react-native-app 1.0.0

package.json:
{
“name”: “Awwwwwe”,
“version”: “0.1.0”,
“private”: true,
“devDependencies”: {
“react-native-scripts”: “1.11.1”,
“jest-expo”: “25.0.0”,
“react-test-renderer”: “16.2.0”
},
“main”: “./node_modules/react-native-scripts/build/bin/crna-entry.js”,
“scripts”: {
“start”: “react-native-scripts start”,
“eject”: “react-native-scripts eject”,
“android”: “react-native-scripts android”,
“ios”: “react-native-scripts ios”,
“test”: “node node_modules/jest/bin/jest.js”
},
“jest”: {
“preset”: “jest-expo”
},
“dependencies”: {
“expo”: “^25.0.0”,
“react”: “16.2.0”,
“react-native”: “0.52.0”
}
}


#4

I’m having the exact same issue after restoring a new MacBook from a backup where the XDEW was working. I’m fairly ready to blame the restore, but I can’t figure out wy the XDE isn’t starting the tunnel, yet “yarn start” in a terminal is.


#5

As a sanity check, perhaps try deleting XDE and then re-installing it? There could also be other cache artifacts affecting things that you need to clear: How to clear the React Native packager.


#6

I did both of those things. I’ll keep trying things.


closed #7

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.