Expo XDE tablet/desktop app error - using unsupported version of Expo SDK (15.0.0) - cannot resolve


#1

Yesterday, i’ve tried to run my react-native project with a simulator on iOS (OS - macOS). However, randomly i’ve got an error on Expo XDE Desktop that the experience couldn’t be loaded because it uses an supported Expo SDk version (15.0.0).

upon searching online, i found that deleting Expo app from the simulator (i’m running Ipad Air 2) helps - I did that and then ran npm run ios --simulator="ipad air 2" again, but the issue persists.

i’ve updated react-native and expo-sdk to their latest versions. the issue is still there.

on desktop, when running my IOS app on the tunnel, it works fine until I scan the QR code with tablet for testing - it throws the same error as above. i deleted the expo app from the actual tablet as well - no success.

what’s happening here? why did it stop working all of a sudden? i’ve been looking for solutions for the past 3h, but no cigar. any help is much appreciated. thanks.

my package.json primary deps:

"babel-plugin-transform-async-to-generator": "^6.24.1",
    "expo": "^21.0.3",
    "react": "~15.4.0",
    "react-native": "^0.49.3",
    "react-native-button": "^2.1.0",
    "react-native-modal": "^4.0.0",
    "react-native-star-rating": "^1.0.8",
    "react-native-stars": "^1.1.0",
    "react-native-swiper": "^1.5.13",
    "react-native-vector-icons": "^4.4.2",
    "react-navigation": "^1.0.0-beta.7",
    "react-redux": "^5.0.3",
    "redux": "^3.6.0",
    "redux-actions": "^2.0.1",
    "redux-thunk": "^2.2.0",
    "styled-components": "^2.2.1"

#2

hi-

sorry this happened to you.

We periodically remove support for old versions of the Expo SDK from the Expo app so that the app doesn’t get too too big. With the latest release, we just removed support for SDK 15.

https://blog.expo.io/expo-sdk-v22-0-0-is-now-available-7745bfe97fc6

If you built a standalone app that uses SDK 15, it will still work, but it will be hard to make changes to it since you won’t be able to use the Expo app.

What we recommend is that you upgrade your project to use the latest SDK – SDK 22.
Here is a guide for how to do that:
https://docs.expo.io/versions/latest/guides/upgrading-expo.html

This is in general a good practice and will get you bug fixes and performance improvements usually that are nice to have. And will make it easier to upgrade – and use new stuff and generally keep up with the current state of the ecosystem – if you do this periodically.

Hope that makes sense and is helpful.

Again, if you published a standalone app, it will continue to work as is, but you should upgrade to a newer SDK to continue development.

Charlie


#3

Hello! thanks for the answer. However, after updating Expo, I ran into dependency hell situation as my app refuses to work when trying various versions of react-native and other libs.

package.json deps:

    "expo": "^22.0.0",
    "react": "^16.0.0-alpha.12",
    "react-native": "^0.49.0",
    "react-native-button": "^2.1.0",
    "react-native-modal": "^4.0.0",
    "react-native-star-rating": "^1.0.8",
    "react-native-stars": "^1.1.0",
    "react-native-swiper": "^1.5.13",
    "react-native-vector-icons": "^4.4.2",
    "react-navigation": "^1.0.0-beta.7",
    "react-redux": "^5.0.3",
    "redux": "^3.6.0",
    "redux-actions": "^2.0.1",
    "redux-thunk": "^2.2.0",
    "prop-types": "^15.6.0",
    "styled-components": "^2.2.1",
    "babel-plugin-transform-async-to-generator": "^6.24.1",

The error of an outdated SDK is no longer there, but there’s a new one - TypeError: undefined is not an object (evaluating '_expo.Components.KeepAwake')

how do I solve this error? is this because of an unsupported react or react-native version?


#4

Ok, I strictly followed the guidelines (here: https://blog.expo.io/expo-sdk-v22-0-0-is-now-available-7745bfe97fc6) for updating to Expo 22.0 and it finally worked.

previously, i’ve tried to run my project on Expo 21.0.0, but it didn’t work out very well… spitting out the error above and so on.

consider this ticket solved.