Expokit 32 - FBAudienceNetwork 4.99 out of date.

#1

Hello,

I need to update FBAudienceNetwork to 5.+ for iOS … I managed to do it via gradle for android but cannot figure it out for iOS.

The error states:

FBAdErrorDetailKey = {
    msg = "The SDK version is in the ad request is no longer supported for new apps. Please upgrade to one of the latest versions of the SDK
}

My Podfile.lock

- ExpoKit/Core (32.0.0):
    - Amplitude-iOS (~> 3.8)
    - Analytics (~> 3.5)
    - AppAuth (~> 0.4)
    - Branch (~> 0.24.2)
    - CocoaLumberjack (~> 3.2.1)
    - Crashlytics (~> 3.8)
    - EXCameraInterface
    - EXConstantsInterface
    - EXCore
    - EXFileSystemInterface
    - EXPermissionsInterface
    - EXReactNativeAdapter
    - EXSensorsInterface
    - Fabric (~> 1.6)
    - FBAudienceNetwork (= 4.99.0)
    - FBSDKCoreKit (= 4.38.1)
    - FBSDKLoginKit (= 4.38.1)
    - FBSDKShareKit (= 4.38.1)
    - Google-Maps-iOS-Utils (~> 2.1.0)
    - Google-Mobile-Ads-SDK (~> 7.22.0)
    - GoogleMaps (~> 2.5.0)
    - GoogleSignIn (~> 4.1)
    - JKBigInteger2 (= 0.0.5)
    - lottie-ios (~> 2.5.0)
    - React

Any help would be much appreicated.

#2

Is there a way I can modify the FBAudienceNetwork dependency myself? I have been trying to use a local ExpoKit podfile but can’t get it to build properly.

Even if I try and just add a new FBAudienceNetwork version in my local Podfile it breaks the dependency with Expokit 32.

closed #3

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.