“Exponent-2.16.1.tar.app” can’t be opened because Apple cannot check it for malicious software.

“This software needs to be updated. Contact the developer for more information.”

I get this error every time I try to launch Expo in my xcode iOS simulator and therefore unable to use it. Android and my physical iPhone works but non cooperative on the iOS simulator. This is using the latest expo-cli and expo 38. This is on the managed workflow.

expo diagnostics

Expo CLI 3.24.2 environment info:
    System:
      OS: macOS 10.15.6
      Shell: 5.7.1 - /bin/zsh
    Binaries:
      Node: 10.16.0 - /usr/local/bin/node
      npm: 6.9.0 - /usr/local/bin/npm
    IDEs:
      Android Studio: 3.5 AI-191.8026.42.35.6010548
      Xcode: 11.3/11C29 - /usr/bin/xcodebuild
    npmPackages:
      expo: ^38.0.0 => 38.0.9
      react: 16.11.0 => 16.11.0
      react-dom: 16.11.0 => 16.11.0
      react-native: https://github.com/expo/react-native/archive/sdk-38.0.2.tar.gz => 0.62.2
      react-native-web: ~0.11.7 => 0.11.7
    npmGlobalPackages:
      expo-cli: 3.24.2

Hi

What happens if you run expo client:install:ios?

If that doesn’t help, try the procedure mentioned here.

1 Like

I still get the same error after using that command and attempting to open Expo. I have also tried erasing all content and settings and then running expo client:install:ios, opening it, and I still get the same error. I never get past the start up screen.

Managed to fix it. I just needed to update xcode.

1 Like

Happy to hear you got things figured out and thanks for sharing the solution with the community!

I figured the same too. I’ve tried installing from xcode 12 to 11.1 and still nothing. I am on OSX Catalina 15.1.1. The dialog that pops up , pops up with this message : “exponent-2.16 was blocked from blocked from” How can I resolve this ?

you have to go to SystemPreferences/Security&Privacy/General
at the bottom you can allow the download