Extracted and locally built expo app stuck on loading screen [iOS] [SDK31]


#1

After creating a simple expo project, exporting it and building it using turtle-cli, the app does not go beyond the loading screen on a device or on a simulator (It does work on Expo Client).
The icon and splash screen image are shown, but it doesn’t go beyond that.
In the system log I found this line:

ExpoKitApp[35341]: assertion failed: 18B75 16B91: libxpc.dylib + 79599 [F7D4B188-D5C2-3E5E-BB76-BC7C6A368166]: 0x7d

Tools I used in my trials:

  • expo-cli v2.3.8 (also tried with v2.3.0, v2.3.5 and v2.3.7)
  • turtle-cli v0.3.3 (also tried with v0.3.1)
  • Ubuntu 18.04 (used for exporting and self-hosting the files)
  • macOS Mojave v10.14.1 (used for building and testing the app)
  • Xcode v10.1 (also tried to downgrade to v9.4.1)
  • node v11.1.0 (also tried to downgrade to v10.13.0)

Device used: iPhone X iOS 12.1
Simulators used: iPhone XR iOS 12.1, iPhone X iOS 12.1, iPhone X iOS 11.4, iPhone 7 Plus 11.4

Steps to reproduce:

expo init (blank template)

Changes to app.json :

  • added “bundleIdentifier” field to “ios” field.

No other changes.

expo export --public-url <host-url>

“Export was successful. Your exported files can be found in …”

Moving to macOS (on the same local network)

Run:
turtle build:ios -t simulator ...

  • This command ran successfully with all the required params. It’s all green without any error messages.

Extract the content of the output file:
tar -xvzf simple-app.ipa

Install the app on the simulator:
xcrun simctl install "iPhone X" ./simple-app.app/

App should be on the simulator. Click the app icon to open it. The app starts and gets stuck on loading screen.

System log shows this line:

ExpoKitApp[35341]: assertion failed: 18B75 16B91: libxpc.dylib + 79599 [F7D4B188-D5C2-3E5E-BB76-BC7C6A368166]: 0x7d

Additional info:

running
expo doctor

“Didn’t find any issues with your project!”

Opening the project on expo-client:
expo start --lan --minify --no-dev

  • The app works normally

I also tried using Expo SDK 30, but it is the same.

Any help is appreciated. Thanks.


closed #2

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.