FaceID Crashing on SDK29

#1

Hi all,

I’m trying to track down why the faceid authentication is crashing… Am I missing anything? Here is what I have

app.json
“sdkVersion”: “29.0.0”,
"ios: { “infoPlist”: {
“NSLocationWhenInUseUsageDescription”: “GENERIC LOCATION MESSAGE”,
“NSFaceIDUsageDescription”: “GENERIC FACEID MESSAGE”
},
}

package.json
“expo”: “^29.0.0”,
“react-native”: “https://github.com/expo/react-native/archive/sdk-29.0.0.tar.gz”,

CODEBASE

const { authenticateAsync } = Expo.Fingerprint;
    const touchMessage = 'Please authenticate to proceed';
    const { success } = (platform.OS === 'ios') ? yield call(authenticateAsync, touchMessage) : yield call(authenticateAsync);

I’m getting this on my simulator

0 Likes

#2

Hey @vlimjap,
FaceID authentication doesn’t work in Expo Client, but works if you have NSFaceIDUsageDescription in infoPlist and build a standalone app. Sorry for this limitation. Also, I think it is not be possible to use FaceID in simulator at all :thinking:
Also, see discussion here: https://github.com/expo/expo/issues/1901#issuecomment-408388545

0 Likes

#3

Hi @tsapeta.

Thank you for your response. It helped. Can you also confirm that faced id also does not work on a published expo build running on an actual device? I am getting this question from this post, https://github.com/expo/expo/issues/1901#issuecomment-399473272

Thanks in advance.

0 Likes

#4

Yes, it should work on apps that were built by expo build, but only if you have NSFaceIDUsageDescription added to infoPlist field in your app.json.

1 Like

closed #5

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

0 Likes