Facing issue while executing Yarn after adding React Navigation and NativeBase to Expo Project


#1

warning “expo > react-native-maps@0.21.0” has incorrect peer dependency “react-native@^0.51 || ^0.52 || ^0.53 || ^0.54”.
warning “expo > react-native-reanimated@1.0.0-alpha.3” has incorrect peer dependency “react@16.0.0-alpha.6”.
warning “expo > react-native-reanimated@1.0.0-alpha.3” has incorrect peer dependency “react-native@^0.44.1”.
warning " > react-native@0.55.4" has incorrect peer dependency “react@16.3.1”.
warning “react-native > eslint-plugin-react-native@3.2.1” has unmet peer dependency “eslint@^3.17.0 || ^4.0.0”.
warning “react-navigation > create-react-context@0.2.2” has unmet peer dependency “prop-types@^15.0.0”.


#2

Hi! Are these warnings causing any problems for your project?


#3

Yes, not able to execute “react-native link” after “yarn add react-navigation native-base”
getting below error


PS C:\Projects\proj> react-native link
Scanning folders for symlinks in C:\Projects\proj\node_modules (81ms)
rnpm-install info Linking assets to ios project
rnpm-install ERR! Something went wrong while linking. Error: Cannot read property ‘pbxprojPath’ of null
Please file an issue here: https://github.com/facebook/react-native/issues



#4

Hey @acuteprofessional,

Is your Expo project detached? Detaching your project creates the ios and android directories needed to make native code configurations such as those automated by the react-native link command.

You can read about detaching here: https://docs.expo.io/versions/v28.0.0/expokit/detach

If your project is detached, then we have another issue on our hands and please let me know!

Cheers,

Adam


#5

Hi @adamjnav, @dikaiosune, this issue has been resolved. my understanding is incorrect.

Thanks for your responses.


#6

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.