Failed building JavaScript bundle on exp sdk 19.0.0.0

#1

Hi,
I try to publish my project but I get this error :frowning:

[exp] Making sure project is set up correctly...
[exp] Your project looks good!
[exp] Unable to find an existing exp instance for this directory, starting a new one...
[exp] Starting React Native packager...
[exp] Scanning 889 folders for symlinks in D:\....\node_modules (53ms)
[exp] Loading dependency graph.
[exp] Running packager on port 19002.
[exp] Publishing...
[exp] Building iOS bundle
[exp] Dependency graph loaded.
[exp] Failed building JavaScript bundle.
[exp] Error: Uncaught error in the transformer worker: D:\....\node_modules\metro-bundler\build\transformer.js
[exp]     at _transform.then.catch.error (D:\...\node_modules\metro-bundler\build\JSTransformer\index.js:147:31)
[exp]     at process._tickCallback (internal/process/next_tick.js:109:7)
[exp] react-packager has encountered an internal error, please check your terminal error output for more details
[exp] Packager URL http://localhost:19002/./node_modules/react-native-scripts/build/bin/crna-entry.bundle?dev=false&minify=true&hot=false&assetPlugin=expo/tools/hashAssetFiles&platform=ios returned unexpected code 500. Please open your project in the Expo app and see if there are any errors. Also scroll up and make sure there were no errors or warnings when opening your project.

package.json

{
  "name": "myApp",
  "version": "0.27.5",
  "private": true,
  "main": "App.js",
  "devDependencies": {
    "jest-expo": "~1.0.1",
    "react-dom": "^15.6.1",
    "react-native-scripts": "1.1.0",
    "react-test-renderer": "16.0.0-alpha.6"
  },
  "scripts": {
    "start": "react-native-scripts start",
    "eject": "react-native-scripts eject",
    "android": "react-native-scripts android",
    "ios": "react-native-scripts ios",
    "test": "node node_modules/jest/bin/jest.js --watch",
     .....
  },
  "jest": {
    "preset": "jest-expo"
  },
  "dependencies": {
    "expo": "^19.0.0",
    "react": "16.0.0-alpha.12",
    "react-native": "^0.46.1",
   ....
  }
}

How to fix this???

UPDATE: downgrade to exp skd 18.0.0 but I still get this error

#2

hi-

I think I’d need to see your whole repository to be able to get to the bottom of this.
Put a link to your project on github here if you like and I’ll try to figure out what’s wrong.

C

#3

I found that react-primitives can’t be executed by Uglify which is enabled in production mode. I don’t know which line in react-primitives code that causes this error.

UPDATE:
This error may be caused by react-primitives
https://github.com/lelandrichardson/react-primitives/issues/83