Fetching the token Failed, message : FIS_AUTH_ERROR

  1. “expo”: “^39.0.3”,
    “expo-cli”: “^3.28.0”,
    “expo-constants”: “~9.2.0”,
    “expo-linking”: “^1.0.3”,
    “expo-location”: “^9.0.0”,
    “expo-notifications”: “^0.7.2”,
    “expo-permissions”: “~9.3.0”,

  2. Platforms Android:

I’m using Expo to build 2 android app, and using 1 Firebase Project. For Notification I’m using expo-notifications. I had uploaded Firebase Server Key to Expo expo push:android:upload --api-key XXX-XXX-XXX . I had configured android app credential in firebase Project Settings with SHA-1 from Google Play Console, then downloaded the latest google-services.json , then placed in app.json and set path android.googleServicesFile : "./google-services.json" . I had configured package name API Google Cloud Platform same as app.json android.package , same as Android App Firebase Project Setting Package Name. I had configured SHA-1 Certificate Fingerprint API Google Cloud Platform and Android App Firebase Project Settings same as SHA-1 Certificate Fingerprint from Google Play Console. I had enabled Firebase Installation API , Firebase Cloud Messaging , FCM Registration API , Cloud Messaging in Google Cloud Platform. I set single user login within my app, so When user did new login, the past of usertoken will be reset to a new token, and another login will be logout. The problem is, one of my app works perfectly, and another one came out with error, it said, Fetching the token Failed, message : FIS_AUTH_ERROR . And Notification is not delivered to broken app.
And I’ve tried change Firebase Server Key with another one, then upload to expo but it came out with Unknown error
Help me please…

you need to set up your firebase api key properly. you can google this error to find things like https://stackoverflow.com/a/60698697/659988

Yes I had set up Firebase API Key properly,

it’s possible that the “SHA certificate fingerprint” part is not correct. if you’re using app signing by google play the fingerprints will be different from what is provided through expo-cli (those will be relevant to the upload cert). you would get this info from here instead if you are using app signing by google play:

also, make sure you have uploaded the api key properly: https://docs.expo.io/push-notifications/using-fcm/#uploading-server-credentials

anyhow, i’m just letting you know that this is working as expected, so you will just need be meticulous about following the setup steps to ensure that everything is configured properly. it’s a bit of a pain, but once you get it set up you can forget about it.

I had typed the SHA-1 and SHA-256 carefully.
Even I put the AppSigning Certificate and Upload Certificate both in Google Cloud Platform and Firebase Project Settings.
I had uploaded FCM Server Key, but When I tried to change the FCM Server Key it turned Unknown Error.

are you using the latest version of expo-cli?

I had cleared the FCM Server Key.
Then I tried to upload again, it turned An unknown error occurred.

are you using the latest version of expo-cli?

YesCapture3 ,

thanks. @quinlanj is looking into why you are seeing this error

Thank you, I’ll wait the good news

hey @moh.jonaidy !

This looks like a bug on our servers and I’ll work on fixing it now.

I’m trying to figure out how your account got into this state, and I’m hoping you can help me with that. Did you ever delete your project from the website and then try to upload your FCM key again?

1 Like

hey @moh.jonaidy,

To unblock you, I’ve manually backfilled your fcm and apps. Please let me know if FCM push notifications work for you now.

I’m in the process of writing a fix, but would prefer not to deploy to our servers unless absolutely necessary because it’s friday evening here. This fix would most likely be deployed early next week, and would prevent this bug from happening in the event apps are deleted from the website, and fcm keys are reloaded

1 Like

Yes I ever deleted keystore from expo and get new keystore.
I was just wondering how case if the keystore change.
Thank you for your help, I’ll wait for the next early week.

hey @moh.jonaidy , sounds good thanks for the update. To clarify, FCM push notifications should work right now on your account – I manually changed it for you.

The deployment next week will fix and prevent other accounts from going into this ‘bad state’ if people delete their projects and try to reupload credentials

I’m really sorry.
This is embarrassing.
Can you manually unblock my FCM push notifications again?
I accidentally cleared the FCM API again.
When I wanted to upload again, it turned An unknown error occurred again.
Thank you for your help.

I’m really sorry.
This is embarrassing.
Can you manually unblock my FCM push notifications again?
I accidentally cleared the FCM API again.
When I wanted to upload again, it turned An unknown error occurred again.
Thank you for your help.