Firebase database not working!


#1

I apologize I cannot provide any more details about this issue because I have no clue how it might have happened. My app uses Firebase services and it was working just fine one day and then the next day with not a single change made … Firebase database only works when remote debugging is disabled … I don’t know if this is a problem with Expo or React native. I just hope that someone might have encountered a similar behavior.


#2

When were you experiencing this? It looks like there was a service disruption of the RTDB yesterday: https://status.firebase.google.com/


#3

Yes it started yesterday !!! Is the disruption still stand ? I can see an indication of a normal operation. still the app only works when debugging is disabled


#4

Use that link I posted to check on the status of Firebase and its services. It looks like services are up and running normally again. If you’re developing with Firebase, I’d suggest bookmarking that page so you can quickly check to make sure services are up and running if you encounter an issue before you start going down a rabbit hole looking for an error on your end. I’ve done that and it isn’t fun.

Sorry, I’m not sure why the RTDB would be affected by remote debugging.


#5

I checked the link and yea it is up and running … which means that my current situation has nothing to do with the RTDB … Can you recommend me somewhere where I can report the problem because I am really confused about what might be causing this sudden unusual behavior. I also just found out that I cannot login into facebook on Android using Expo.logInWithReadPermissionsAsync … It was working fine as well and now the loading spinner keeps spinning until I get an unhandled promise of a connection error


closed #6

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.