Firebase not installing in terminal

#1

How can I connect firebase with my app. I’m unable to install firebase. I’m getting this message:

npm WARN eslint-config-exponent@5.1.3 requires a peer of eslint@^3.10.2 but none is installed. You must install peer dependencies yourself.
npm WARN moment@1.0.0 No repository field.

firebase@4.4.0
updated 1 package in 3.207s

#2

This doesn’t look like firebase actually failed to install – seems like there are just some optional dependency mismatches. Are you finding that firebase isn’t actually installed?

#3

Do you know how to fix it and make sure that it only uses one dependency. Yes, I’m finding that it is not installed

#4

I would check the node_modules folder and make sure that firebase isn’t there, as it looks like it was installed.

Otherwise you can install the peer dependency and eslint with
npm install --save firebase@4.4.0 eslint-config-exponent@5.1.3 eslint@3.10.2