Found some duplicated unimodule packages. Installed the ones with the highest version number.

Found some duplicated unimodule packages. Installed the ones with the highest version number.
Make sure following dependencies of your project are resolving to one specific version:
expo-constants, expo-firebase-core, expo-updates

Recently I ejected my managed workflow. All are fine except these warnings.

I followed the suggestion here Dependency Issue SDK34 ~> SDK35 · Issue #5895 · expo/expo · GitHub but it doesn’t help. How can I proceed further? Thanks!

You can uninstall packages like expo-constants that are included in unimodules.

1 Like

Thank you! I removed those 3 from my own dependency list due to eject. But still expo-constants gives the warning. I have reinstalled node dependencies, Pods, but doesn’t help. Any idea of other dependency could be the issue?

  "dependencies": {
    "@expo/react-native-action-sheet": "^3.8.0",
    "@neverdull-agency/expo-unlimited-secure-store": "^1.0.10",
    "@react-native-async-storage/async-storage": "^1.13.3",
    "@react-native-community/blur": "^3.6.0",
    "@react-native-community/masked-view": "0.1.10",
    "@react-native-community/netinfo": "^5.9.10",
    "@react-native-community/segmented-control": "2.2.2",
    "@react-native-community/viewpager": "4.2.2",
    "@react-navigation/bottom-tabs": "^5.11.7",
    "@react-navigation/native": "^5.9.2",
    "@react-navigation/stack": "^5.14.2",
    "@reduxjs/toolkit": "^1.5.0",
    "@sentry/react-native": "^2.1.1",
    "@sharcoux/slider": "^5.0.4",
    "axios": "^0.21.1",
    "expo": "^40.0.1",
    "expo-auth-session": "~3.0.0",
    "expo-av": "~8.7.0",
    "expo-crypto": "~8.4.0",
    "expo-firebase-analytics": "~2.6.0",
    "expo-haptics": "~8.4.0",
    "expo-image-picker": "~9.2.0",
    "expo-linear-gradient": "~8.4.0",
    "expo-linking": "~2.0.1",
    "expo-localization": "~9.1.0",
    "expo-random": "~10.0.0",
    "expo-secure-store": "~9.3.0",
    "expo-splash-screen": "~0.8.1",
    "expo-status-bar": "~1.0.3",
    "expo-store-review": "~2.3.0",
    "expo-video-thumbnails": "~4.4.0",
    "expo-web-browser": "~8.6.0",
    "i18next": "^19.8.5",
    "lodash": "^4.17.20",
    "react": "16.13.1",
    "react-dom": "16.13.1",
    "react-i18next": "^11.8.5",
    "react-native": "~0.63.4",
    "react-native-animated-spinkit": "^1.5.1",
    "react-native-blurhash": "^1.0.29",
    "react-native-fast-image": "^8.3.4",
    "react-native-feather": "^1.0.2",
    "react-native-gesture-handler": "~1.9.0",
    "react-native-htmlview": "^0.16.0",
    "react-native-image-zoom-viewer": "^3.0.1",
    "react-native-reanimated": "^2.0.0-rc.2",
    "react-native-safe-area-context": "3.1.9",
    "react-native-screens": "~2.17.1",
    "react-native-shared-element": "^0.7.0",
    "react-native-svg": "12.1.0",
    "react-native-tab-view": "^2.15.2",
    "react-native-tab-view-viewpager-adapter": "^1.1.0",
    "react-native-toast-message": "^1.4.3",
    "react-native-unimodules": "~0.12.0",
    "react-navigation-shared-element": "^3.0.0",
    "react-query": "^3.6.0",
    "react-redux": "^7.2.2",
    "react-timeago": "^5.2.0",
    "redux-persist": "^6.0.0",
    "rn-placeholder": "^3.0.3",
    "sentry-expo": "^3.0.4",
    "tslib": "^2.1.0"
  },

run yarn why expo-constants to see where it’s coming from

you can also use the yarn resolutions field to force everything to use the same version

1 Like

Thanks for the info you shared. Keep suggesting such content. I am looking for the same issue.

Thanks! Posting my result in case others are interested.

=> Found "expo-constants@9.3.5"
info Has been hoisted to "expo-constants"
info Reasons this module exists
   - Hoisted from "expo-auth-session#expo-constants"
   - Hoisted from "react-native-unimodules#expo-constants"
   - Hoisted from "expo#expo-constants"
   - Hoisted from "expo-linking#expo-constants"
info Disk size without dependencies: "240KB"
info Disk size with unique dependencies: "3.32MB"
info Disk size with transitive dependencies: "92.96MB"
info Number of shared dependencies: 162
=> Found "sentry-expo#expo-constants@10.0.1"
info This module exists because "sentry-expo" depends on it.
info Disk size without dependencies: "776KB"
info Disk size with unique dependencies: "2.69MB"
info Disk size with transitive dependencies: "91.42MB"
info Number of shared dependencies: 153

myaarpmedicare

Thanks for sharing. What did you end up doing? Just manually removing dependencies that are part of unimodules? I’m in a similar situation:

Found some duplicated unimodule packages. Installed the ones with the highest version number.
Make sure following dependencies of your project are resolving to one specific version:
 expo-application, expo-keep-awake, expo-constants, expo-font, expo-updates, expo-secure-store

Yes that is what I did. But there is still 1 warning remaining I forgot whichone, think it is expo-constants. But I just ignore it for now, nothing breaks.

1 Like