Generate androidStandaloneAppClientId help

#1

I am trying to build standalone app but cannot generate androidStandaloneAppClientId needed for google login. I follow this documentation here: https://docs.expo.io/versions/latest/sdk/google.html
But I cannot generate Signing-certificate fingerprint with my keytool version.
-jarfile is not a valid option. Where can I find correct version of keytool? I am running Expo on a Mac

0 Likes

#2

keytool is on your mac, you can double check in the terminal with which keytool.

What is your full command? Are you sure there are no syntax errors?

0 Likes

#3

Thanks for your answer, As you can see below I do not have the -jarfile option.

which keytool
/usr/bin/keytool

keytool -help
nyckelverktyg:

-certreq [-v] [-protected]
[-alias ] [-sigalg ]
[-file <csr_fil>] [-keypass <nyckell?senord>]
[-keystore ] [-storepass <lagringsl?senord>]
[-storetype ] [-providername ]
[-providerclass <provider_class_name> [-providerarg ]] …
[-providerpath ]

-changealias [-v] [-protected] -alias -destalias
[-keypass ]
[-keystore ] [-storepass <lagringsl?senord>]
[-storetype ] [-providername ]
[-providerclass <provider_class_name> [-providerarg ]] …
[-providerpath ]

-delete [-v] [-protected] -alias
[-keystore ] [-storepass <lagringsl?senord>]
[-storetype ] [-providername ]
[-providerclass <provider_class_name> [-providerarg ]] …
[-providerpath ]

-exportcert [-v] [-rfc] [-protected]
[-alias ] [-file ]
[-keystore ] [-storepass <lagringsl?senord>]
[-storetype ] [-providername ]
[-providerclass <provider_class_name> [-providerarg ]] …
[-providerpath ]

-genkeypair [-v] [-protected]
[-alias ]
[-keyalg ] [-keysize ]
[-sigalg ] [-dname ]
[-validity ] [-keypass <nyckell?senord>]
[-keystore ] [-storepass <lagringsl?senord>]
[-storetype ] [-providername ]
[-providerclass <provider_class_name> [-providerarg ]] …
[-providerpath ]

-genseckey [-v] [-protected]
[-alias ] [-keypass ]
[-keyalg ] [-keysize ]
[-keystore ] [-storepass <lagringsl?senord>]
[-storetype ] [-providername ]
[-providerclass <provider_class_name> [-providerarg ]] …
[-providerpath ]

-help

-importcert [-v] [-noprompt] [-trustcacerts] [-protected]
[-alias ]
[-file ] [-keypass <nyckell?senord>]
[-keystore ] [-storepass <lagringsl?senord>]
[-storetype ] [-providername ]
[-providerclass <provider_class_name> [-providerarg ]] …
[-providerpath ]

-importkeystore [-v]
[-srckeystore ] [-destkeystore ]
[-srcstoretype ] [-deststoretype ]
[-srcstorepass ] [-deststorepass ]
[-srcprotected] [-destprotected]
[-srcprovidername ]
[-destprovidername ]
[-srcalias [-destalias ]
[-srckeypass ] [-destkeypass ]]
[-noprompt]
[-providerclass <provider_class_name> [-providerarg ]] …
[-providerpath ]

-keypasswd [-v] [-alias ]
[-keypass <gammalt_nyckell?senord>] [-new <nytt_nyckell?senord>]
[-keystore ] [-storepass <lagringsl?senord>]
[-storetype ] [-providername ]
[-providerclass <provider_class_name> [-providerarg ]] …
[-providerpath ]

-list [-v | -rfc] [-protected]
[-alias ]
[-keystore ] [-storepass <lagringsl?senord>]
[-storetype ] [-providername ]
[-providerclass <provider_class_name> [-providerarg ]] …
[-providerpath ]

-printcert [-v] [-file ]

-storepasswd [-v] [-new <nytt_lagringsl?senord>]
[-keystore ] [-storepass <lagringsl?senord>]
[-storetype ] [-providername ]
[-providerclass <provider_class_name> [-providerarg ]] …
[-providerpath ]

keytool -list -printcert -jarfile ~/Downloads/test.apk | grep SHA1 | awk '{ print $2 }'
Ogiltigt alternativ: -jarfile
Try keytool -help

0 Likes

#4

What is output of $ sw_vers

0 Likes

#5

sw_vers
ProductName: Mac OS X
ProductVersion: 10.12.6
BuildVersion: 16G29

0 Likes

#6

Also have the same problem on another mac:
sw_vers
ProductName: Mac OS X
ProductVersion: 10.10.5
BuildVersion: 14F2511

0 Likes

#7

@magnusros It seems like keytool has the -jarfile option in a newer version of the binary. Try updating keytool.

new version:
http://docs.oracle.com/javase/7/docs/technotes/tools/solaris/keytool.html

old version:
https://docs.oracle.com/javase/6/docs/technotes/tools/solaris/keytool.html

0 Likes

#8

Thanks:slight_smile:

0 Likes