getting error trying to run expo start

I’m getting this error trying to run expo start. Could you please advise?

(base) arun@arun-HP-Pavilion-g6-Notebook-PC:~/Documents/react_native_test$ expo start
Starting project at /home/arun/Documents/react_native_test
Expo DevTools is running at http://localhost:19002
Your project is in SDK version >= 33.0.0, but the expo package version seems to be older.
Opening DevTools in the browser... (press shift-d to disable)
Cannot find module 'expo/tools/LogReporter'
Require stack:
- /home/arun/Documents/react_native_test/noop.js
Set EXPO_DEBUG=true in your env to view the stack trace.
(base) arun@arun-HP-Pavilion-g6-Notebook-PC:~/Documents/react_native_test$

Hi.

Try upgrading your version of expo-cli to 3.0.10.

Did update to the latest but still getting the same error.


(base) arun@arun-HP-Pavilion-g6-Notebook-PC:~/Documents/react_native_test$ expo start
Starting project at /home/arun/Documents/react_native_test
Expo DevTools is running at http://localhost:19002
Your project is in SDK version >= 33.0.0, but the expo package version seems to be older.
Opening DevTools in the browser... (press shift-d to disable)
Cannot find module 'expo/tools/LogReporter'
Require stack:
- /home/arun/Documents/react_native_test/noop.js
Set EXPO_DEBUG=true in your env to view the stack trace.
(base) arun@arun-HP-Pavilion-g6-Notebook-PC:~/Documents/react_native_test$ expo --version
3.0.10

Did you upgrade your app from an earlier SDK? If so, please check the upgrade instructions again to see if maybe a step has been missed.

Also, please post the output of expo diagnostics.

One thing in particular to check:

In app.json you need to specify the SDK version:

{
  "expo": {
...
    "sdkVersion": "34.0.0",
...
  }
}

And this must correspond with what you have in package.json:

{
...
  "dependencies": {
    "expo": "^34.0.3",
...
    "react": "16.8.3",
    "react-native": "https://github.com/expo/react-native/archive/sdk-34.0.1.tar.gz",
...
  },
...
}

The upgrade instructions will tell you what to specify for those SDK versions and dependencies. You might also want to create a new project with expo init and then compare the app.json and package.json to your app.

I am pretty sure that doing the above will fix this error:

Your project is in SDK version >= 33.0.0, but the expo package version seems to be older.

I’m not sure about the following error:

Cannot find module 'expo/tools/LogReporter'

but there’s a good chance it will fix that too. If not, try removing your node_modules and re-running npm install or yarn (depending on which one you use to manage your dependencies).

This is the diagnostic info:

(base) arun@arun-HP-Pavilion-g6-Notebook-PC:~/Videos/mytestreactnative$ expo diagnostics

  Expo CLI 3.0.10 environment info:
    System:
      OS: Linux 4.15 Linux Mint 19 (Tara)
      Shell: 4.4.20 - /bin/bash
    Binaries:
      Node: 12.4.0 - ~/.nvm/versions/node/v12.4.0/bin/node
      npm: 6.9.0 - ~/.nvm/versions/node/v12.4.0/bin/npm
    npmPackages:
      react: 16.8.3 => 16.8.3 
      react-native: ^0.60.5 => 0.60.5 
    npmGlobalPackages:
      expo-cli: 3.0.10

Hi. This does not look like an expo project. Did you run expo diagnostics from the root of your project? How did you create the app to begin with?

There is no expo dependency and the react-native dependency is wrong for an expo app.

Also, you did not answer any of my questions and have given no indication that you checked the things I suggested.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.