How can I upload a legacy Apple push notification p12 certificate?

Expo cli now has support to the new push notification authentication token with the p8 certificate. But we need to use the legacy p12 push notification service.

We can not find how can a set the p12 cert path in expo cli but the expo docs says that p12 legacy push notification certificate can be used.

Expo CLI 3.20.0 environment info:
    System:
      OS: Linux 5.3 Linux Mint 19.3 (Tricia)
      Shell: 4.4.20 - /bin/bash
    Binaries:
      Node: 12.13.1 - ~/.nvm/versions/node/v12.13.1/bin/node
      Yarn: 1.21.1 - /usr/bin/yarn
      npm: 6.14.5 - ~/.nvm/versions/node/v12.13.1/bin/npm
    npmPackages:
      expo: ^37.0.0 => 37.0.8 
      react: 16.9.0 => 16.9.0 
      react-native: https://github.com/expo/react-native/archive/sdk-37.0.1.tar.gz => 0.61.4 
      react-navigation: ^4.0.0 => 4.3.8 
    npmGlobalPackages:
      expo-cli: 3.20.0

We deprecated support for push certificates about a year ago, there is no way to provide a new certificate. Certs currently in use are still working, but we plan to remove API for that when all certs expire.

But we need to use the legacy p12 push notification service.

Why? If there is a good reason for needing that we might reconsider it.

expo docs says that p12 legacy push notification certificate can be used.

Can you provide a link to docs that state that?

Thanks for your quick answer Wkozyra!.

Our client does not want to give Expo the ability to send push notifications to all their applications. There is no way to achieve that with the p8 certificate.

The outdated docs are here:

https://docs.expo.io/distribution/security/

Says:

There are two types of iOS push notification credentials: one modern recommended approach recommended by Apple and the legacy approach. The default behavior is to use the modern approach, but developers may opt in to the legacy approach by providing a p12 certificate.

Regards.

Our client does not want to give Expo the ability to send push notifications to all their applications. There is no way to achieve that with the p8 certificate.

Expo does not have any knowledge about device tokens for other apps, so there is no way to send notifications there. If it’s not enough the only way I see to support your use case would be ejecting.

The outdated docs are here:

Thanks for pointing that out, I’ll update the docs