How do I get the Expokit build to use the new Expo CLI?

#1

I’ve switched over to expo-cli for everything… or so I thought. I just ran my first Expokit build in a few weeks, and noticed that several of the build steps were warning about updating exp, e.g.,:

:app:bundleDevMinSdkDevKernelReleaseExpoAssetsThere is a new version of exp available (57.2.0).
[22:57:38]: ▸ You are currently using exp 56.0.0
[22:57:38]: ▸ Run `npm install -g exp` to get the latest version

Is there a way to get Expokit to use the new CLI? I’m assuming the old one will be cut off at some point. I’m on SDK 29 FWIW.

Thanks!

#2

Hi @llamaluvr! Thanks for reporting this oversight on our part. You can now update to expokit@1.7.1 in your root project to fix this.

1 Like
Detached Expo project migration from SDK 24 to 30
#3

Does this require updating to Expo 30, as well, or can I use this package with Expo 29? I just upgraded the node module to 1.7.1, and now I’m getting a lot of errors on my Android build about it not being able to find “ExpoView 29” files.

#4

@llamaluvr sorry for the slow followup! You’d need to upgrade to SDK 30 in order to use this new package. In the meantime, while you’re still on SDK 29 I’d recommend just keeping exp installed globally. There’s no problem with having both exp and expo-cli installed at once.

1 Like
closed #5

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.