How to build a customised expokit-npm-package


#1

Hallo,

I need to make some changes to ExponentNetwork and ExponentHttpClient classes in the ExpoView project under the expo/expo repo. I want the changes to reflect in a local expokit-npm-package that is compatible with expokit 1.7.1, and will work with an Expo SDK 30 detached application.

I am able to build all my changes into .aars just fine but can’t figure out how to correctly package expokit for local npm. Am I missing a script or a gradle task somewhere?

Cheers


#2

+1 I need to know this myself


#3

Hi all – if you check out the android/sdk30 branch on the expo/expo repo, the expokit-npm-package folder should contain exactly the contents of version 1.7.1 currently on NPM. The script that we use to update this package when there are changes to expoview is gulp update-exponent-view --abi 30.0.0 inside of the tools folder, so you can try running that. (Make sure to npm install/yarn in both the tools and tools-public directories first.)


How can I use a forked version of Expo with Android to build/publish
Build Custom Expokit 1.7.1 for sdk30.0.0
#4

Thank you very much for this info!


closed #5

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.