How to run expo in interactive mode?

#1

I am curently running an issue when trying to build my expo app (react-native) for ios.
When running the command exp build:ios i got the folowing error :

[18:11:15] Error while gathering & validating credentials
[18:11:15] Input is required, but exp is in non-interactive mode.
Required input:

How would you like to upload your credentials?

Its mean my expo application is running in non-interactive mode and that why it cannot accept an input while running. I would to know how i could fix this issue.

0 Likes

#2

Hey @erwanriou,

If seen this happen before, out of curiosity what OS are you running on and what terminal are you using?

Cheers,

Adam

0 Likes

#3

Hey @adamjnav, yeah i saw one other personn that might had the same problem, but wasn’t any solution proposed.

So i am currently working on windows 7 with a bash terminal (the one you get when installing git). I was doing the test on my physical device, an iphone 5.
Expo app and test on my phone are all working fine (i launch the app with npm start just get the QR code to read it on my phone.

I start to think that this is a shell TTY problem but i am not sure…

2 Likes

closed #4

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

0 Likes