How to run with dev mode off / does no-dev flag work?

#1

I’m trying to troubleshoot an issue that only happens when I publish my JS bundle, so I’d like to run my app from my machine with the dev flag turned off. I thought the --no-dev flag on exp would do that. However, when I run exp start --no-dev, the “Running application “main” with appParams:” section on the commandline still shows that it’s running in the dev mode, including bits like:

"bundleUrl":"http://192.168.1.67:19001/node_modules/expo/AppEntry.bundle?platform=android&dev=true&minify=false&hot=false

and

"packagerOpts":{"dev":true,"lanType":"ip","hostType":"tunnel","minify":false,"urlRandomness":"y7-hjw"}

and

 __DEV__ === true, development-level warning are ON, performance optimizations are OFF

Is this the right way to turn dev mode off, or is there another way?

1 Like
#2

Interesting… it does work when I turn off the Development Mode flag in XDE, just not from the exp command line.

#3

haha, so when I closed the XDE and went back to exp, then exp was stuck on dev mode being turned off. So I had to open XDE again, turn development mode on, run it, close it, and then I could go back to using dev more on exp.

1 Like
closed #4

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.