How to tell if a react native package will work in Expo?

#1

How to tell if a react native package will work in Expo?

Are they usually the ones that require react-native link or some manual installation?

Thanks.

#2

In short, yes - if they require you to run react-native link or perform some manual setup in Xcode/Android Studio, it won’t work with Expo as it’s dependent on custom native modules.

If you want to use such a library, you have two options:

  1. Detach to ExpoKit
  2. Find and vote for a request to add the library on canny, or create a new feature request
#3

if I detach to expokit, i can still use the expo api like mapview etc right?

#4

Yes.

https://docs.expo.io/versions/v27.0.0/expokit/detach

closed #5

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.