Icons missing on real device

Hi,

I am trying to use ‘@expo/vector-icons’ and it seems to work fine when using the Web viewer. However when previewing on a real device using the expo app it does not appear correctly.

Here is a link to the very simple snack: https://snack.expo.io/@stephenheron/icon-test

Any ideas?

Thanks,
Stephen

1 Like

Hi

I saw something like this the other day, but ran out of time to figure it out. I am not sure if this problem is specific to snacks. When I exported the snack and ran it locally it still failed (although I think it crashed, if I remember correctly.) If I created a new project with expo init ...; expo install @expo/vector-icons and then copied and pasted the App.js from the snack into the new app it worked correctly. I was not able to find the relevant differences between the exported snack and the new app in the time I had available. At one point I was also getting a Chinese character instead of the expected AntDesign icon on the device, while the web preview showed the correct icon.

Sorry I can’t remember the details better. Maybe try creating an app locally with expo init and see if you still get the same results.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.