In Android Emulator Expo SDK requires Expo to run error

#1

Hi.
Am trying to test the app in Android Studio emulator, but am running into an error.
Android_Emulator_-_Nexus_6_API_28_5554

I am using “expo”: “^31.0.4”, “sdkVersion”: “31.0.0” and expo --version: 2.6.13.

#2

Hey @vayu,

Can you try uninstalling and re-installing the Expo Client from the emulator and see if that fixes the error?

Cheers,

Adam

#3

Thanks Adam for the tip, I have now tried, but am not sure if I did it the correct way. I opened the Android emulator and opened Apps, and uninstalled from there. I then installed it again, but the same error happens.

#4

I followed the instructions here: https://docs.expo.io/versions/latest/workflow/android-studio-emulator
Could it be the hardware type that I have chosen, that doesn’t work?

closed #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.