Inherited v18.0.0 project - need to deploy


#1

I have inherited an Expo app build against the 18.0.0 SDK. It is unfortunately already in production and urgent (small) changes need to be deployed.

I have run into several issues

  • current EXPO android client will not load v18.0.0 apps - fortunately production is running an older android expo client 2.2.0 so they can still run the app

  • I can no longer publish changes to expo.io due to older version

  • is there any way around this without having to move through all the upgrade steps? There is more risk in breaking things by changing versions but I see no way to get these latest small changes to the Expo client


#2

I understand the reasoning behind deprecating older versions but I would also dearly like to see some way of still building old code.

Being able to replicate old builds is really important / useful, and “old” here is just 6 months old.

Is there any possibility in the future of allowing the builds to use an older Expo client, to support this type of thing? Unmaintained / unsupported so the Expo team don’t have the pain of having to maintain it.

Example case: freelancer completes a project, archives it, 6 months later the client wants a minor change and expects that they have a working source tree but it no longer works. They have to pay to, or the freelancer has to free-of-charge upgrade through several versions, fix any deprecations, changes in components (maps, react nav etc), just to get back to the code the customer thought was a working app.


#3

Hi! We’re currently working on a couple of projects to make this less painful, hopefully we’ll have some stuff to announce soon.

In terms of working around these issues today, there are a few things that we can help with.

First, you can still download Android client v2.2.0 and iOS client v2.2.0 for simulators from our CDN. We don’t make it super easy to find those URLs, but all of the old releases can still be downloaded.

I can no longer publish changes to expo.io due to older version

Can you share more about the specific error you’re seeing? AFAIK our devtools should still be backwards compatible with sdk 18.

@mlight I definitely agree! We’re currently working on making our standalone app build service build any SDK version going forward, but it’ll take some time to support. It is possible to build a standalone app for ~any version of the client by cloning the repo and checking out the relevant release commits. We tag the iOS releases which you can usually use to find the right version of the code to build. The README section on standalone apps provides instructions. As I said, we’re hoping to improve and automate this process more in the near future, but these are a couple of potential paths to unblocking yourselves.


#4

Thanks for the feedback!

I made another pass at publishing and found out my issue was not with the Dev tools. I am now able to publish my v18.0.0 project to expo.io and open it in the older 2.2. 0 Android client without issue.

The only change I had to make was that on the device running the Expo client, I can no longer sign into my expo account (message says connection disabled) to select the project. I now need to open the URL using the Expo app. This is ok and works.

So now I am able to push small changes quickly while I move through the upgrade steps on another branch.

Thanks for your support!


#5

This is great, thanks for the feedback!


closed #6

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.