Invalid Bundle error when uploading IPA

I got this error when uploading the IPA via Application Loader:

ERROR ITMS-90596: “Invalid Bundle. The asset catalog at ‘Payload/ExpoKitApp.app/GoogleMaps.bundle/GMSCoreResources.bundle/Assets.car’ can’t be processed. Rebuild your app, and all included extensions and frameworks, with the latest GM version of Xcode and resubmit.”

The IPA just got built maybe 15 minutes ago.

Any help thanks!!

Hey @sunwayedu,

You’ll need to upgrade your Xcode to the latest version to remedy this, which unfortunately also gets rid of Application Loader. For now, you’ll need to use the xcrun cli. You can find the steps here: https://docs.expo.io/versions/v35.0.0/distribution/uploading-apps/#manually-uploading-your-app

Cheers,
Adam

Right i’ll give that a try. Thank you.

1 Like

Let me know if you run into any issues!