iOS 14 Simulator issue

For reference, I’m on the MacOS Big Sur Beta, with Xcode 12 installed.

When I run my app on a simulator, there’s an endless warning that Expo has pasted content from the CoreSimulatorBridge.

This is the typical iOS 14 alert that an app has pasted content from another place.
The exact message is, “Expo pasted from CoreSimulatorBridge.”

If this only happened once, when starting the app, there’d be little issue. But since this keeps popping up every second and never stops, it’s difficult to continue work as it blocks the header.

For clarification, this does not happen on a real device running iOS 14, only on the simulator.

I’m certain this is simply an iOS 14 issue, but I figured I’d mention it just in case someone had a fix. Thanks!

1 Like

It’s super annoying!!! Like dealing with bugs aren’t enough annoying now this one.

1 Like

For now, you can just kill the Expo app in the simulato. Then run it and open the project. This will resolve the clipboard popups. Not a solution, but it is workaround.

run expo client:install:ios and install the latest version of expo client for sdk 38 (2.17.2) and it will resolve this issue

2 Likes

after upgraded the latest version of expo-cli 3.27.6 this morning, I no longer see the popup. I guess they might have fixed it maybe because of I killed the simulator for some reasons.

For me even after the update to expo-cli 3.27.6 is still happening :confused:

I still see this issue on 3.27.6 too.
The workaround from @soukupl works to temporarily get rid of the pop ups.

It seems that is a React Native problem, expo will have to be updated right away. :frowning:

update to the latest version of expo client to resolve the issue. to do this, update from the app store for your physical device or run expo client:install:ios for simulator