ios build error with multiple profiles found in AppStore

#1

This is the error I’m getting:

Error: Reason: Unexpected response, raw: {
“responseId”: “2a77020e-3380-4796-aad9-0249b11ff9bd”,
“resultCode”: 35,
“resultString”: “There were errors in the data supplied. Please correct and re-submit.”,
“userString”: “Multiple profiles found with the name ‘app.wheatpaste.mobile AppStore’. Please remove the duplicate profiles and try again.”,
“creationTimestamp”: “2018-12-12T13:01:55Z”,
“protocolVersion”: “QH65B2”,
“userLocale”: “en_US”,
“requestUrl”: “https://developer.apple.com/services-account/QH65B2/account/ios/profile/createProvisioningProfile.action”,
“httpCode”: 200,
“validationMessages”: [
{
“validationKey”: “provisioningProfileName”,
“validationUserMessage”: “Multiple profiles found with the name ‘app.wheatpaste.mobile AppStore’. Please remove the duplicate profiles and try again.”
}
]
}
at IOSBuilder._throwIfFailureWithReasonDump (/expo-cli@2.6.12/src/commands/build/IOSBuilder.js:672:13)
at IOSBuilder._callee6$ (/expo-cli@2.6.12/src/commands/build/IOSBuilder.js:348:10)
at tryCatch (/opt2/wp-mobile-app/node_modules/regenerator-runtime/runtime.js:62:40)
at Generator.invoke [as _invoke] (/opt2/wp-mobile-app/node_modules/regenerator-runtime/runtime.js:296:22)
at Generator.prototype.(anonymous function) [as next] (/opt2/wp-mobile-app/node_modules/regenerator-runtime/runtime.js:114:21)
at step (/opt2/wp-mobile-app/node_modules/babel-runtime/helpers/asyncToGenerator.js:17:30)
at /opt2/wp-mobile-app/node_modules/babel-runtime/helpers/asyncToGenerator.js:28:13
at process._tickCallback (internal/process/next_tick.js:68:7)

I tried revoking the certificates in the Apple Developer site and even deleting the app from the AppStore but nothing is working.

As a caveat, I had tried doing this with another Expo account that I got locked out of that I can’t recover since the forgot password functionality on Expo is not working, so I switched to my regular user.

Thanks for your help!

After publishing App, how to know if App successfully in App Store and Google Apps?
#2

I was able to solve this by manually creating all the required certificates on the Apple side of things.

#3

Glad you were able to solve things and thanks for sharing the solution with the community! I’ll raise the password reset functionality issue internally.

Cheers,

Adam

#4

Hi @esfoobar. Would you mind explaining what you did to fix this? I have created one certificate in Xcode, which is visible on my Apple Developer account under all certificates.
Furthermore, I have one profile under Provisioning profiles->Distribution.
I still get this same error as you did. Hope you could help. :slight_smile:

#5

Hi @vayu,

I followed this guide and App Store Connect’s instructions on how to create the certificates manually. You need two p12 certs, one is for distribution, associated with your team, and the other for the Apple Notification Service. Just add the plus sign here to create them, then download to your Mac and open the files. They’ll be added to your keychain. Then you can export them as p12 which is what the expo cli requires.

You’ll also need a Distribution Provisioning profile that you create and that you also download. The caveat with that file is that the extension is .mobileprovision but Expo requires the file to be a .mobile file, so I just renamed it to .mobile.

Once you have these 3 files locally, start the expo build process but select the manual build, not letting Expo do it for you.

I had to pay extra attention to create the certificates with the correct iOS App ID bundle because I had two from my earlier issue with a locked Expo account, so I used my personal one, but that led to two bundles from the two different Expo build runs.

Good luck!

– Jorge

2 Likes
closed #6

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.