IOS Managed Expo App - Asking for Camera Permissions when not needed

Please provide the following:

  1. SDK Version: 39
  2. Platforms(Android/iOS/web/all): iOS

I have a strange problem, since upgrading from Expo SDK 37 to 39 using the CLI, when running the app on iOS it now asks for permissions to access the Camera Roll (photos), however there is no reference to the Camera permissions anywhere in the code, and this is not needed for the app.

It has now been rejected by the Apple store and i’m not sure how to resolve this.

Any suggestions on how to resolve this?

Many Thanks.

What’s the rejection message you received from Apple?

When you run your app, you see the “Allow access to Camera” prompt? If you do, you should find where in your app that’s happening and the responsible code

Hi @charliecruzan,

Thanks for getting back to me.

Apple have rejected it based on the following:

“We noticed that your app requests the user’s consent to access the camera, but doesn’t sufficiently explain the use of the camera in the purpose string.”

Which I think makes sense, as for some reason the app is requesting this permission to access the camera roll, but we are not using it for any functionality, so there is no description as to why we need this access.

I have been looking through the code base and there is no reference to any ‘expo-permissions’ or any code setting or requesting permissions from the user for iOS. I am currently slightly confused as to were this is now coming from.

It has only appeared since upgrading to SDK 39 and usage on iOS 14.

After further investigation, its linked to the new permission types apple have added into iOS 14.

Its linked to the PHOTO_LIBRARY Permissions which is a new variant.

Is there a way in Expo to stop the request of this?

Thanks,

@nc-preqin I’m not getting that prompt when I build for iOS on SDK 39. Can you provide a sample project that doesn’t request photo permissions anywhere in the code, but does result in that system prompt?