Issue on iOS but not web: "Exception thrown while executing UI block"

Please provide the following:

  1. SDK Version: 40.0.0
  2. Platforms(Android/iOS/web/all): iOS. Issue does not occur on Web.

I get the following error only on iOS, not on Web. According to my log message output, all React components render but still this error message is thrown and when I dismiss it, the screen is all black.

Since the error message does not really state any React component or function, I’m at my wit’s end here.
I tried a debugging session but even with “Pause on exceptions” it does not stop and point to a code line.

Can anyone provide a clue which component might be the culprit?
As stated above, the app runs perfectly fine on the Web platform.

My package.json:

{
  "homepage": "__masked__",
  "main": "node_modules/expo/AppEntry.js",
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "web": "expo start --web",
    "eject": "expo eject",
    "test": "jest --watchAll"
  },
  "jest": {
    "preset": "jest-expo"
  },
  "dependencies": {
    "@expo/vector-icons": "^12.0.0",
    "@react-native-async-storage/async-storage": "^1.13.2",
    "@react-native-community/masked-view": "0.1.10",
    "@react-navigation/bottom-tabs": "^5.11.2",
    "@react-navigation/native": "^5.8.10",
    "@react-navigation/stack": "^5.12.8",
    "dayjs": "^1.9.6",
    "expo": "^40.0.0",
    "expo-application": "~2.4.1",
    "expo-asset": "~8.2.1",
    "expo-constants": "~9.3.3",
    "expo-font": "~8.4.0",
    "expo-linking": "~2.0.0",
    "expo-localization": "~9.1.0",
    "expo-random": "~10.0.0",
    "expo-screen-orientation": "~2.1.0",
    "expo-splash-screen": "~0.8.1",
    "expo-status-bar": "~1.0.3",
    "expo-web-browser": "~8.6.0",
    "i18n-js": "^3.8.0",
    "luxon": "^1.25.0",
    "react": "16.13.1",
    "react-dom": "16.13.1",
    "react-native": "https://github.com/expo/react-native/archive/sdk-40.0.0.tar.gz",
    "react-native-gesture-handler": "~1.8.0",
    "react-native-safe-area-context": "3.1.9",
    "react-native-screens": "~2.15.0",
    "react-native-svg": "^12.1.0",
    "react-native-web": "~0.13.12"
  },
  "devDependencies": {
    "@babel/core": "~7.9.0",
    "@expo/config": "^3.3.3",
    "@types/react": "~16.9.35",
    "@types/react-native": "~0.63.2",
    "jest-expo": "^40.0.0",
    "typescript": "~4.0.0"
  },
  "private": true
}

Anyone ?

you should downgrade your react-native-svg (.eg 9.3.x)