Issue running app

#1

Im trying to get my first app running using CRNA but can’t get it to run in iOS simulator or on phone.

I had various warnings of unmet/missing dependencies after running CRNA. Eventually got to just this one:

npm ERR! peer dep missing: @babel/core@7.0.0-beta.38, required by @babel/plugin-check-constants@7.0.0-beta.38

A number of other apps rely on a more recent version of this package so I seem to have hit a bit of a wall here.

Some info about what I’m using:

react-native-scripts@1.14.0
react-native@0.55.3
expo@27.0.1
node v8.4.0
npm 4.6.1
yarn 1.5.1

Thanks.

#2

Hey @gavjamhug! Can you give more information about where you’re hitting this error? Is this when running yarn start?

#3

Hey @jesse! I run into the same issue running both yarn start and yarn ios.

Running yarn start the packager starts and I then get the error when i hit i top open the iOS simulator.

#4

Ok thanks! I just tired it with a fresh install of CRNA and it worked for me. I’m not really sure what’s going on, but maybe try rm -rf node_modules && yarn or just manually install @babel/core@7.0.0-beta.38?

#5

Thanks @jesse I tried that but still have the same issue.

Is there anything I should think about reinstalling / updating maybe?

closed #6

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.