Issue with Image disappearance

  1. SDK Version: 39
  2. Platforms(Android/iOS/web/all): Android

I have upgraded my expo to version 3.28.1.
In my app I have a reaction bar like instagram’s but I’m using images instead of icons, basically when the user clicks on the image the image appears else the image gets a tintColor: “#000”, this used to work like a charm before, but after the update it doesn’t work, now I get the black tinted image but when I click on the image, it no longer is visible. This is an example for one of the images:

<TouchableOpacity
            onPress={() => setLike(!didLike)}
            style={PostStyle.Reactions}
          >
            <Image
              source={require("../images/like.png")}
              style={didLike ? PostStyle.Liked : PostStyle.Like}
            />
          </TouchableOpacity>

the following styles are:

Like: {
      resizeMode: "contain",
      width: "100%",
      tintColor: "#000",
    },
    Liked: {
      resizeMode: "contain",
      width: "100%",
    },
Reactions: {
      resizeMode: "contain",
      aspectRatio: 1 / 1,
      flex: 1,
      flexDirection: "row",
      justifyContent: "center",
      alignItems: "center",
      width: "30%",
      margin: 5,
    },

any idea what’s wrong?

Hey @shreehari, upgrading the cli version alone should not have an impact on this. Can you try to identify some other changes that may be the culprit here? Is this occurring locally or with a published/standalone app as well?

Cheers,
Adam

Actually I had never bundled this app before, Its still very early in development…after updating when I saw that the images were disappearing I thought there was some problem with the expo android app (which I use for development) and then I bundled it…which didn’t work. As for other culprits…I have installed some additional dependencies and I never tested the reaction part after installing those dependencies, I can list my dependencies if you want.

found the solution here.
ps thanks @adamjnav for the reply

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.