Jest-expo and babel-preset-expo both archived - is there a replacement?


#1

I’ve recently been trying to get tests working on my CRNA project. The only test we have is the one that comes with it out of the box (App.test.js) and as I understand it that should just work when running yarn test. This isn’t the case, and looking into it further it turned out Jest wasn’t picking up the preset or correctly transpiling the code, so it’d then choke on import statements which Node doesn’t understand.

After some more investigation, I found that both the jest-expo and babel-preset-expo projects have recently been archived on Github. Are these now deprecated, and if so, what is replacing them? I can’t find any mention as to why they’ve been archived, or any updated documentation indicating how to set up testing in an Expo/CRNA project.


#2

hello! the packages live here: https://github.com/expo/expo/tree/master/packages

for import problem specifically please see https://jestjs.io/docs/en/tutorial-react-native#transformignorepatterns-customization


#3

Ah ok, thanks! It’d be great if someone could add a note to the README.md for each of the archived projects to show where they’ve moved to. Google has no idea that the new locations exist.


#4

The READMEs on the two repos now point to their new locations. We’ll remove the separate repos one day too so the old repos don’t show up in search results.


#5

Great, thanks for sorting that out so quickly. It looks like the npm pages also need updating when you get a chance, but as the Github now redirects it’s unlikely to confuse anyone too much.


closed #6

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.