Map View crashed on stand alone app

I’m building an app using EXPO and this is my first experience for creating react native app.
I have just completed my project and every this working fine on local/Expo development tool. When I create standalone app of my project and go to MapView screen app crashes and when I again go to same screen map is showing but hang my app. Also I’m using google login, push notifications, deep linking all are working fine on Expo development tool but not working on standalone app.
Also I’m using SHA1 certificate from https://expo.io/accounts/myexpoaccount/projects/map-view-standalone-app/credentials and using in firebase and google.console.com

app.json
{

“expo”: {

"packagerOpts": {

  "config": "metro.config.js",

  "sourceExts": [

    "expo.ts",

    "expo.tsx",

    "expo.js",

    "expo.jsx",

    "ts",

    "tsx",

    "js",

    "jsx",

    "json",

    "wasm",

    "svg"

  ]

},

"scheme": "App",

"name": "App",

"slug": "App",

"version": "1.4.0",

"orientation": "portrait",

"icon": "./assets/icon.png",

"splash": {

  "image": "./assets/splash.png",

  "resizeMode": "cover",

  "backgroundColor": "#64985f"

},

"updates": {

  "fallbackToCacheTimeout": 0

},

"assetBundlePatterns": [

  "**/*"

],

"ios": {

  "supportsTablet": true,

  "bundleIdentifier": "com.mypakagename",

  "config": {

    "googleSignIn": {

      "reservedClientId": "my-reservedClientId.apps.googleusercontent.com"

    },

    "googleMapsApiKey": "MY KEY"

  },

  "googleServicesFile": "./GoogleService-Info.plist"

},

"android": {

  "adaptiveIcon": {

    "foregroundImage": "./assets/adaptive-icon.png",

    "backgroundColor": "#FFFFFF"

  },

  "package": "com.mypakagename",

  "googleServicesFile": "./google-services.json",

  "config": {

    "googleMaps": {

      "apiKey": "MY KEY"

    }

  }

},

"web": {

  "favicon": "./assets/favicon.png"

},

"description": ""

}

}

Hey @ncashofficial2021, just to be sure you followed the steps listed here MapView - Expo Documentation and it’s crashing still?

Also, can you let me know what SDK version you are building with? Another resource that could be useful to you would be our debugging docs on production errors.

Cheers,
Adam

Thank @adamjnav for reply… I followed the steps also double check it.
SDK Version: 40.0.0

One more thing google map works fine on IOS which I’ve already upload on test flight. But it’s not working on android… Also google login, facebook login, push notifications and deep linking not working on both platform in standalone app.