[MapView] [Android] Custom Components are not being displayed over the map

#1

Hi, I want to render a searchbar (I’m using GooglePlacesAutoComplete for that component) over the MavpView, but it isn’t being displayed over the map on android.

In iOS I don’t have any problem with that. Any idea why is this hapening?

My package json

{
  "main": "node_modules/expo/AppEntry.js",
  "private": true,
  "dependencies": {
    "axios": "^0.17.1",
    "expo": "^23.0.0",
    "firebase": "^4.8.0",
    "react": "16.0.0",
    "react-native": "https://github.com/expo/react-native/archive/sdk-23.0.0.tar.gz",
    "react-native-app-link": "^0.4.0",
    "react-native-elements": "^0.18.4",
    "react-native-google-places-autocomplete": "^1.3.6",
    "react-native-google-static-map": "^0.1.11",
    "react-native-modal-dropdown": "^0.6.0",
    "react-native-modalbox": "^1.4.2",
    "react-native-star-rating": "^1.0.8",
    "react-native-timer": "^1.3.1",
    "react-navigation": "^1.0.0-beta.27",
    "react-redux": "^5.0.6",
    "react-timer-mixin": "^0.13.3",
    "redux": "^3.7.2",
    "redux-persist": "^5.4.0",
    "redux-thunk": "^2.2.0",
    "socket.io": "^2.0.4",
    "socket.io-client": "^2.0.4",
    "validate.js": "^0.12.0"
  }
}

Note: I’ve already tried zIndex and elevation.

0 Likes

#2

Hi @sagomezza - could you post a snack that reproduces this issue? It’s hard for us to help debug without an easy repro case.

0 Likes

closed #3

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

0 Likes