Metro Bundler fail after upgrade to 33

Just updated to v33 and receive the below message on “expo start”:

error: unknown option `–assetPlugins’

Metro Bundler process exited with code 1
Error: Metro Bundler process exited with code 1
at ChildProcess. (/@expo/xdl@54.1.1/src/Project.js:1598:16)
at Generator.next ()
at step (/usr/local/lib/node_modules/expo-cli/node_modules/@expo/xdl/build/Project.js:2347:191)
at /usr/local/lib/node_modules/expo-cli/node_modules/@expo/xdl/build/Project.js:2347:437
at new Promise ()
at ChildProcess. (/usr/local/lib/node_modules/expo-cli/node_modules/@expo/xdl/build/Project.js:2347:99)
at ChildProcess.packagerProcess.once (/@expo/xdl@54.1.1/src/Project.js:1595:5)
at Object.onceWrapper (events.js:281:20)
at ChildProcess.emit (events.js:193:13)
at Process.ChildProcess._handle.onexit (internal/child_process.js:255:12)

1 Like

OK, I think I figured out what happened, should anyone else experience this issue. After upgrading my project, when I ran ‘expo start,’ I got a warning about un-optimized images. So before I ran the project again, I ran ‘expo optimize.’ HOWEVER, since I hadn’t yet updated my CLI (at least not globally), the ‘.expo-shared’ directory was not created… which meant the CLI threw the above error every time I tried to run the project.

The .expo-shared directory is independent from Metro. You likely encountered the error above because of an outdated version of Expo CLI.