Metro Bundler failed to start. (code: EACCES)

#1

Ubuntu 18.04

I get this when trying to start expo in an existing project. I have checked so that I have ownership of .expo in the repositroy as well as .expo in my home directory. What more can I check? Been going through all links related to this and debugging for a day now. Any help is greatly appriciated.

SOLUTION:

I solved it. The problem was that metro bundler (the program that builds your js files) could not connect to my android emulator. This was due to that the emulator was created by a root user, so therefor metro bundler did not have the correct permissions so therefor it threw a EACCES error.

What I did was to create a new android emulator with my users permission, then it worked.

#2

It would be helpful to mention all the things you’ve tried so far.
Also letting us know the type of OS you are running on, the version of Expo…
Have you tried this?

#3

Os: Ubuntu 18 LTS
Exp version: 55.0.2
Have tried the link that you’ve sent.
Kinda hard to specify what i haven’t tried. Been at this for 2 days now following all links that I can find. What is causing this, is this problem known?

Thanks!!

closed #4

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.