Minimum Xcode requirement for Expo ipa itunes upload??


#1

Hey there.

I have recently had issues with my usual laptop. And i have currently had to attempt an iOS store upload on an older mac.

I am using expo 27.0.0 and have built my IPA as per usual and attempting to upload via application loader.

Current specs.
Expo 27.0.0
Mac OS 10.10.5
XCode 7.2.1 (Latest 10.10.5 could support from what i’ve read)
Application Loader 3.4 (What came with xcode).

I am hitting an invalid bundle error.

ERROR ITMS-90596: “Invalid Bundle. The asset catalog at ‘Payload/ExpoKitApp.app/GoogleMaps.bundle/GMSCoreResources.bundle/Assets.car’ can’t be processed. Rebuild your app, and all included extensions and frameworks, with the latest GM version of Xcode and resubmit.”

From what i have read online people with similar issues had to update their xcode. But i probably can’t on this older laptop.

Just wondering if expo has a minimum spec requirement for xcode/application loader to succeed?

Cheers in advance.


#2

Hello

Yes, you have to get XCode 10 to upload builds. It’s not quite Expo requirement but we build apps with XCode 10 and to upload them you have to get the same version.


#3

Rightio, all good.

Thanks for the reply @jakubste


closed #4

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.