Module parse failed: Unexpected token

Hello, I have been trying to make a PWA file from my currently working app, but I keep getting the same error in different modules (one example below). I don’t know if i am missing something in the implementation or if these are modules that are not currently supported.

Failed to compile.
/home/mark/Documents/HENRY/Osmind/osmind-mobile/node_modules/static-container/StaticContainer.js 5:21
Module parse failed: Unexpected token (5:21)
You may need an appropriate loader to handle this file type, currently no loaders are configured to process this file. See https://webpack.js.org/concepts#loaders
| 
| export default class extends Component {
>     static propTypes = {
|         shouldUpdate: PropTypes.bool.isRequired
|     };

I followed the instructions in expo documentation but can’t get past this error.
Thank you for your time.