New bare project

Hi, I just create a new project, with expo init projectbare
With Bare minimal
After finishes, when I do the yarn android

Shows an error here:
Task :unimodules-react-native-adapter:compileDebugJavaWithJavac FAILED
Deprecated Gradle features were used in this build, making it incompatible with Gradle 7.0.

  • What went wrong:
    Execution failed for task ‘:unimodules-react-native-adapter:compileDebugJavaWithJavac’.

Please if anybody can help me with this, any hint or something.

expo-cli 4.7.3
Node 12.16
Windows 10

can you share the full error?

Yes, thanks.


Task :unimodules-react-native-adapter:compileDebugJavaWithJavac FAILED

Deprecated Gradle features were used in this build, making it incompatible with Gradle 7.0.
Use ‘–warning-mode all’ to show the individual deprecation warnings.
See Command-Line Interface
278 actionable tasks: 3 executed, 275 up-to-date
C:\Users\info\apps\react-native-2021\projec-bare\node_modules\expo-modules-autolinking\build\index.js:14
.option(’-i, --ignore-paths <ignorePaths…>’, ‘Paths to ignore when looking up for modules.’, (value, previous) => (previous ?? ).concat(value))
^

SyntaxError: Unexpected token ‘?’
at wrapSafe (internal/modules/cjs/loader.js:1071:16)
at Module._compile (internal/modules/cjs/loader.js:1121:27)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:1177:10)
at Module.load (internal/modules/cjs/loader.js:1001:32)
at Function.Module._load (internal/modules/cjs/loader.js:900:14)
at Module.require (internal/modules/cjs/loader.js:1043:19)
at require (internal/modules/cjs/helpers.js:77:18)
at [eval]:1:1
at Script.runInThisContext (vm.js:120:20)
at Object.runInThisContext (vm.js:311:38)
C:\Users\info\apps\react-native-2021\projec-bare\node_modules@unimodules\react-native-adapter\android\src\main\java\org\unimodules\adapters\react\ModuleRegistryAdapter.java:26: error: cannot find symbol
mModuleRegistryProvider = new ReactModuleRegistryProvider(new ExpoModulesPackageList().getPackageList(), null);
^
symbol: class ExpoModulesPackageList
location: class ModuleRegistryAdapter
1 error

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:unimodules-react-native-adapter:compileDebugJavaWithJavac’.

Compilation failed; see the compiler error output for details.

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at https://help.gradle.org

BUILD FAILED in 44s

error Failed to install the app. Make sure you have the Android development environment set up: Setting up the development environment · React Native. Run CLI with --verbose flag for more details.
Error: Command failed: gradlew.bat app:installDebug -PreactNativeDevServerPort=8081
C:\Users\info\apps\react-native-2021\projec-bare\node_modules\expo-modules-autolinking\build\index.js:14
error Command failed with exit code 1.
info Visit yarn run | Yarn for documentation about this command.


Thanks!

Hi, any news about this error? maybe a way to solve it. Thanks!

Hi

Sorry, I’m not sure what the problem is, but could you let us know what you’re trying to accomplish? These days with EAS Build/expo run, Config Plugins, etc. you are much less likely to have to use the bare workflow.

Also, I saw somewhere that creating a Managed workflow app and then running expo eject might possibly be a bit more robust than creating a bare app directly from expo init.

Thanks, yes that way works for me, creating it managed and then eject. Thanks a lot, I always work with managed projects, but I was trying the bare workflow.

Thanks again,

1 Like