New update available, downloading...

Please provide the following:

  1. SDK Version: 38
  2. Platforms(Android/iOS/web/all): IOS

Expo IOS client hangs in splash screen with “New update available, downloading…”

This happens on any new release channel.


I just ran into the issue. Impossible to launch the app in neither android or iOs. It is stuck on “New update available, downloading…”.

SDK: 39

Edit: After restarting the computer, it now eventually throws

Failed to connect to debugger!
Timeout while connecting to remote debugger

Is this when you’re opening a published project (expo publish) or running the project locally with expo start? It might be helpful to know your environment info (run expo diagnostics)


I have the exact same problem, I have published an app with SDK 37.0.0 and from some phones scanning the QR code from the apps page works, while in mine (Huawei Mate 20 Lite) it hangs in “New update available, Downloading…”.

I have tried restarting the phone, clearing the cache of the Expo Client, reinstalling the client, and the problem still remains.

¿Any clue on how to debug this?

I managed to fix it by doing this:

  • expo upgrade (force upgrade)
  • delete the node_modules folder
  • delete package-lock.json
  • npm install

I think the expo upgrade part can be skipped if you wish to stay on SDK 37.


Same problem when I publish my application. I have 2 Android phones, it’s run on the first one but on the other I alway have Expo client hangs in splash screen with “New update available, downloading…”.
I have to kill the Expo client “linked” to the application who try to load new update, (but not Expo client himself) and the second time I ask for my application it’s run. But this is not a fix, because if I switch off my Android phone and try to lunch my application, I have again the splash screen with “New update available, downloading…”.
1- I try to desinstall Expo client on the Android phone and re-install : Not running.
2- I try to delete node_modules folder, delete package-lock.json, npm install, expo start, Re publish with another url : Not running.
3- My environment on the laptop who publish the application (run expo diagnostics ) :
Expo CLI 3.27.14 environment info:
OS: Linux 5.4 Linux Mint 20 (Ulyana)
Shell: 5.0.17 - /bin/bash
Node: 14.13.0 - /usr/bin/node
Yarn: 1.22.0 - ~/.yarn/bin/yarn
npm: 6.14.8 - /usr/bin/npm
expo: ~36.0.0 => 36.0.2
react: ~16.9.0 => 16.9.0
react-dom: ~16.9.0 => 16.9.0
react-native: => 0.61.4
react-native-web: ~0.11.7 => 0.11.7
expo-cli: 3.27.14
Expo Workflow: managed

This is what I did.

I test my app on an Android Studio Emulator and whenever it gets stuck, I close the app instance from the ‘Recent apps drawer’ on Android.

Don’t close the Expo app you use to launch the RN app.
You should only close the RN app instance you’re working on.
Closing both of them, would lead to the same problem again.


I am having this problem as well. Client constantly showing “New update available, downloading” message. App only loads sometimes. Client version 2.17.4, Expo-cli version 2.28.2.

Roll back to the previous working code and incrementally add your new code. This is how I found a bug that was causing this issue

i have the same issue. any can resolved it??

this is my expo diagnostics

Expo CLI 3.13.8 environment info:
OS: macOS Mojave 10.14.6
Shell: 3.2.57 - /bin/bash
Node: 12.18.2 - ~/.nvm/versions/node/v12.18.2/bin/node
Yarn: 1.22.10 - /usr/local/bin/yarn
npm: 6.14.5 - ~/.nvm/versions/node/v12.18.2/bin/npm
Android Studio: 3.4 AI-183.6156.11.34.5692245
Xcode: /undefined - /usr/bin/xcodebuild
expo: ~39.0.2 => 39.0.4
react: 16.13.1 => 16.13.1
react-native: => 0.63.2

I have the same issue. Really frustrating because you have to wait when you start the simulator for the first time.

What was the bug you found?

I have same problem…

My phone android say:

"New update available, downloading…”.

I have same problem.
expo diagnostics:
Expo CLI 3.28.5 environment info:
OS: macOS 10.15.6
Shell: 5.7.1 - /bin/zsh
Node: 12.18.4 - ~/.nvm/versions/node/v12.18.4/bin/node
Yarn: 1.22.4 - /usr/local/bin/yarn
npm: 6.14.6 - ~/.nvm/versions/node/v12.18.4/bin/npm
Watchman: 4.9.0 - /usr/local/bin/watchman
CocoaPods: 1.9.3 - /usr/local/bin/pod
Platforms: iOS 14.0, DriverKit 19.0, macOS 10.15, tvOS 14.0, watchOS 7.0
Android Studio: 4.0 AI-193.6911.18.40.6626763
Xcode: 12.0.1/12A7300 - /usr/bin/xcodebuild
expo: ^39.0.0 => 39.0.3
react: 16.13.1 => 16.13.1
react-dom: 16.13.1 => 16.13.1
react-native: => 0.63.2
react-navigation: ^4.3.9 => 4.3.9
expo-cli: 3.28.5
Expo Workflow: managed
I have faced with this problem when using android real device. The device has api level 23. The android emulator and ios simulator work fine. Any idea why it’s happening? Or any solution?

We’re also receiving this error. This has only begun to happen when we published to a release channel.

The error is occurring both in the expo app on android, and the emulator on the project page itself.

Expo CLI 3.27.12 environment info:
OS: Linux 5.4 Ubuntu 20.04.1 LTS (Focal Fossa)
Shell: 5.8 - /usr/bin/zsh
Node: 14.9.0 - ~/.nvm/versions/node/v14.9.0/bin/node
npm: 6.14.8 - ~/.nvm/versions/node/v14.9.0/bin/npm
expo: ^39.0.0 => 39.0.5
react: 16.13.1 => 16.13.1
react-dom: 16.13.1 => 16.13.1
react-native: => 0.63.2
react-native-web: ~0.13.7 => 0.13.18
expo-cli: 3.27.12
Expo Workflow: managed

Clearing app data in phone settings worked for me


I went to Setting ->Apps->Expo->Storage and clear storage,cache .Sometimes it works, sometimes not, I don’t know why, it happens very randomly